15

I'm facing this issue after updating iOS11 in my recently bought iPhone 7

I usually turn off wifi during the night and found it ON in the morning. It automatically turns ON resulting in unnecessary battery drains.

Would appreciate a fix !!

3
  • I guess I got the issue. I'll verify & post the answer here. When I'm turning wifi OFF from control center by swiping upwards, it is just disconnecting but not turning wifi off. I guess in order to turn WIfi OFF, I've to go to Settings>>Wifi OFF. I need to verify this. Commented Sep 28, 2017 at 5:11
  • Just came across this question and I'm a little perplexed because I don't experience this problem, although my behaviour is a little different. In my case I use the Control Centre each night to switch on Aeroplane Mode. This switches off Wi-Fi and Bluetooth and they remain off until I disable Aeroplane Mode in the morning. Sometimes this is well after 5am. So, is my experience different to yours in this regard? I'm running iOS 11.0.3, but I'm pretty sure it's been this way for each version of iOS 11.
    – Monomeeth
    Commented Oct 31, 2017 at 23:25
  • Shortcuts introduced in iOS12 could be helpful. You may create a shortcut to turn WiFi / Bluetooth on / off.
    – tsh
    Commented Sep 20, 2018 at 8:48

1 Answer 1

13

WiFi & Bluetooth under iOS 11 will both automatically switch back on at 5am.

The only way to completely disable either is from Settings.

If you want to completely disable Wi-Fi and Bluetooth for all networks and devices, follow these steps:

  • To turn off Wi-Fi, go to Settings > Wi-Fi and turn off Wi-Fi.

  • To turn off Bluetooth, go to Settings > Bluetooth and turn off Bluetooth.

Refs:

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .