2

I had some files on an old thumb-drive, and recently I was going through and discovered that all/most of the files were no longer readable by any of my macs. I seam to remember having similar problems like this while back, and finding an apparent link to my choice of format, so I ran diskutil list in terminal:

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *134.2 GB   disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS my-old-files            133.9 GB   disk3s2

And I tried ls -l

total 3858320
-rw-r--r--@  1 kipbits  staff     3430100 Nov 21  2016 2015-12-24.pdf
drwxr-xr-x   8 kipbits  staff         272 Sep 26  2016 2016-sep-14-files
-rw-r--r--   1 kipbits  staff    25642888 May 18  2015 myold.mp4
-rw-r--r--@  1 kipbits  staff         884 Jul 31 20:20 someold.txt
-rw-r--r--@  1 kipbits  staff  1320157184 Sep 21  2016 someold.iso
drwxr-xr-x   4 kipbits  staff         136 Sep 27 16:23 anotherdir
-rw-r--r--@  1 kipbits  staff   626214959 Nov  5  2016 someold.mp4
drwxr-xr-x  14 kipbits  staff         476 Nov  2  2016 sept2016files

I think this looks normal?

The problem is, I'm not able to open any of my files. I get the following errors:

pdf:

**The file “some-old.pdf” could not be opened.**
It may be damaged or use a file format that Preview doesn’t recognize.

txt: 800 byte files are blank

rtf:

**The document “some-old.rtf” could not be opened.** 

mp4:

**QuickTime Player can't open "some-old.mp4".**
To see if additional software is available that will enable QuickTime Player to open the movie, click Tell Me More.

dmg, iso: will mount but did not test further

pkg:

**The operation couldn’t be completed. (com.apple.installer.pagecontroller error -1.)**
Couldn't open "some-old.pkg"

I found a thread on apple saying "The partition map type doesn't really make any difference for non bootable volumes", although i don't get any of these problems when using Master Boot Record & ExFAT.

None of the files are more than a couple years old, so i don't think there should be any compatibility issues, and none of the files were corrupted when I copied them to the drive. I have had this same problem with other drives, and they were perfectly usable after reformatting, although this involved erasing files.

My question is: Is there a way to recover my files? The file-sizes still display that the files are there. Is there a way to save these files and make them readable?

...Also, if it makes any difference, I am using El Capitan(for dev purposes)

Update------------------------------------------------------------------------------------------------(04/Oct/2017)

I did a hexdump for some of the files in question. my output was something like this:

 0000000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
*
 0000370 00 00 00 00                                    
 0000374

what does this mean? do you think a recovery app could even help me here?

here are some threads that are perhaps related:

...Also could this possibly be related to SIP? I first noticed this problem around when i first upgraded to El Capitan.

Or perhaps there is something else going on? I have recently been experimenting with windows and various forms of linux, and have been moving files around with thumb drives. Perhaps I plugged one in to the wrong computer and corrupted all the files?

Whatever the cause, I'm wondering if the files might still be recoverable? Is hexdump a good way to diagnose recoverability? Would buying a recover app just be a waste of $100?

  • 1. Partition table type ≠ file system 2. Catalog file entry ≠ file on disk 3. Flash cell data retention? - What do you expect us to answer except: get a recovery app (one example of several q&a here) and try a disk content based (not catalog based!) data recovery or search and attach your backup drive. – klanomath Sep 28 '17 at 2:41
1

I would first try Disk Utility. You will find it in the Utilities folder in your Applications folder. In the left pane, select your disk, and at the top, click on the SOS button. Otherwise I have had some luck with DiskWarrior and with Data Rescue, but these software are not free.

  • Thanks, I will look into one of the above. I am still left wondering what could be the cause. this has happened at least 3 times now. and every time it has been with a drive formatted for GTP & OSXextended. I don't know if there is a connection, because i was looking around today, and i have some other drives formatted the same way, with no corrupt files. It is not every day you run into this kind of problem, but it is a major show stopper when it happens. – kipbits Oct 3 '17 at 21:33
0

Well, I found an old copy of DiskWarrior 4 laying around, and I decided to give it a shot. DiskWarrior Did find that there were damaged files, although it only identified a subset of the files i know to be damaged. I also tried to rebuild a volume to which i had copied some damaged files. No Luck, I think they are gone forever. Fortunately I do have copies of most of it elsewhere, although there are a few things I lost for good(teary eyes). I think the most helpful thing i have found from all this is some terminal commands for viewing files in binary(hexdump, xxd perhaps there are others?).

I'm still not sure what caused all this, although I think it is important to note that this drive may have been plugged in to a system that did not recognize it. I guess the takeaway is simply to be more careful with my flash media?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .