1

My iMessage and FaceTime suddenly stopped working with my Apple ID on my Macbook Pro (OS X 10.9.5) during my vacation at NYC.

Even on my iPhone (iOS 10.3.3) I can now only use iMessage and FaceTime with my phone number, but not with my Apple ID independent from my location.

Everytime I try to activate iMessage and FaceTime on my MacBook and my iPhone following error is shown:

An error occurred during activation

I've checked my Date & Time settings and the current location to be true, reset NVRAM and checked all my settings, but there is no solution in sight. I also deleted my Apple ID accounts from all my Apple devices and reconnected them after a reboot of each device, like recommended by Apple and several other webpages.

Does anyone know a possible solution, or has similar problems?

I don't want to update my Mac or iPhone. The solutions provided to the question Messages won't let me sign in to iMessage suggesting to clear NVRAM and to delete the keychain don't work for me, and iMessage and FaceTime do work but only with my phone number.

  • Have you tried contacting Apple? – Allan Sep 27 '17 at 15:21
  • @Allan and no I did not contact Apple, but I will soon :-) I really appreciate that you think out of the "update iOS and OS X"-box – scherzkrapferl Sep 27 '17 at 15:32
  • Does the Console.app show anything interesting when you try to sign in on your Mac, perhaps from the identityservicesd process? (Thanks for your replies, I've cleaned up the comments here to focus on the problem) – grg Sep 27 '17 at 15:54
  • @grgarside not it does not I'm afraid! I also checked the process with htop and it showed no unusual behavior (Maybe I should mention that I had to change my PATH variable right now to access htop - quite an unusual behavior after using macports for 2 years. Maybe there is something bigger going on on my macbook). Thanks for cleaning the comments - I'm here too to focus on the problem :) – scherzkrapferl Sep 27 '17 at 16:08
0

This sometimes happened to me when I reset my iPhone/iPad and have to activate them again. Most of the time it was due to connection issues with Apple activation servers. I would just switch from WiFi to 4G/LTE (vice versa) and it works. Or maybe you can test with another Apple ID, or try to reset your network setting.

  • Thanks for the answer, I've tried it a few times but it still doesn't work. Probably there is currently an issue with the Apple activation servers because sometimes it takes a minute to tell me that an error occurred. – scherzkrapferl Sep 27 '17 at 17:19
0

I was able to solve the problem by updating to macOS High Sierra.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .