15

While upgrading to macOS Sierra I accidentally enabled storage of my Desktop & Documents Folders in iCloud. I quickly reversed that by disabling the option, then moving my files back to their place on my local drive.

Even though the option is now disabled on all my macOS account, I still cannot delete the Desktop and Documents folders from iCloud Drive. No matter what I do, they keep coming back moments after being deleted.

I tried the following with no success:

  • Delete the folders from the affected macOS account;
  • Delete the folders from another macOS account connected to the same iCloud account (I never enabled the option on this account);
  • Turn off the MacBook and delete the folders from Files on iOS;
  • Delete the folders from icloud.com;

No matter what I do, these two folders keep coming back moments later. This leads to the Dektop and Documents folders local to my MacBook being renamed to Desktop — Local and Documents — Local respectively, which is quite annoying.

How can I delete these two folders from iCloud Drive?

3 Answers 3

18

From my MacBook's Finder window, I deleted the empty Desktop folder from iCloud Drive and then immediately emptied the trash before the folder had time to reappear in iCloud Drive. The folder did not reappear.

After a few seconds iCloud refreshed and the Documents folder was deleted from my iOS device as well!

I then followed the same steps to delete the empty Documents folder.

Cheers!

0
4

Using trash works for me as well.

There is a delete immediately (in case you don't want to empty trash, also easier than racing to beat the iCloud Drive restore of Desktop and Documents) option - click OPT+CMD+Delete

There are prompts to answer to confirm the in place deletion you must answer for the delete to happen.

1
  • 1
    Thanks for sharing this option, on a bigger screen it was hard getting back to empty trash before it was restored. This did it straight away.
    – Lee
    Sep 8, 2019 at 11:43
1

2020: It's still happening using macOS 11.1 Big Sur

I had a small file on the Desktop that I deleted in Finder, it went in the bin as expected. Every time I emptied the bin then file would reappear in the bin after a few seconds.

Delete using Finder

I tried the methods mentioned here by Kevin R. & ROG:

  • Emptying trash immediately: nope
  • CMD + OPT + Delete: nope
  • Renaming the file, then deleting: nope
  • Moving the file out of an iCloud Drive folder: nope

Also tried from Terminal using rm -f. The file reappeared every time.

Online iCloud Drive

Sign-in to iCloud drive via https://www.icloud.com/iclouddrive/

The file was there in the Recently Deleted page so I deleted the file from there. It did disappear from my Mac's bin and them promptly reappeared after a few seconds on the Recently Deleted page and on my Mac.

I reasoned iCloud Drive identifies files by hashing their contents and that's why the rename would not work. The file's hash was stuck somewhere in the sync process.

What worked for me:

To remove the file, firstly alter it's contents, in this case I renamed it to be a .txt file, then opened the renamed file in a text editor, added some extra random characters, then saved the file. As the contents changed, the hash used by iCloud also changed.

After deleting the updated file, it no longer reappeared in the bin, or anywhere else. SUCCESS!

So alter the contents of the file, then delete.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .