9

After upgrading, I noticed my terminal got extremely slow (MBP 2013). There is a noticeable input delay, moving the window or switching to another application lags and skips the animation. I noticed the background needs around 1s to recreate the opacity/blur effect after window switching, so I tried disabling the effect in the settings, which restored previous performance completely.
Is this a known issue? I'd like to have my transparent, blurred background back.

  • I also get this on rMBP 2016 – Josh Click Oct 6 '17 at 23:06
6

So, for completeness' sake since there doesn't seem to be a better answer as of yet, I'll add my solution.
If your Terminal.app started showing the behavior outlined in the question and you have modified the blur/opacity settings, turning these off will restore previous performance. To do so, open the terminal settings ( + ,), switch to the Profile tab and click on the background color picker next to color & effects. Here, set the faders for opacity and blur to 100%.

Screenshot of the Terminal settings

If someone finds a way to enable transparency again without trashing performance, I'll be happy to accept their answer.

  • Surely you meant to set blur to 0%, not 100%? – Théophile Jan 7 '18 at 23:24
  • @théophile nope, I meant 100%. In the meantime, I figured out this doesn't matter if opacity is set to 100% because that'll disable all blur effects anyway and causes the terminal to work normally again. – Moritz Friedrich Jan 7 '18 at 23:27
  • Thanks, I see. I too guessed that it wouldn't matter with opacity at 100%, but wouldn't it be better to set it to 0% as a default? Or is the operating system default already 100%? – Théophile Jan 7 '18 at 23:43
  • I actually don't know. Yes, that might be better, but it doesn't seem to matter. – Moritz Friedrich Jan 8 '18 at 17:21
1

Ran into the same problem. For me it's just the blur effect. Transparency does not cause me issues. It seems to be the case for other terminal apps too, (I tried iTerm2, and as soon as I enabled it's blurred background effect it had the same performance issues). This is all since the High Sierra upgrade.

For now I'm disabling blur to get around the problem. Hope it gets addressed soon.

  • Did you experience this same lag in Sierra with blur enabled? – Max Coplan Mar 25 '19 at 17:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .