5

I've downloaded "Install macOS High Sierra.app" from the Apple App Store. On launching I get:

"This copy of the Install macOS High Sierra.app application is damaged, and can‘t be used to install macOS."

This error can be fixed by following the steps (from https://discussions.apple.com/thread/7675283?start=0&tstart=0):

  1. Go to your applications folder.
  2. Find the installer.
  3. Right click on the installer and click "Show Package Contents".
  4. Click on the folder named "Contents".
  5. Click on the folder named "SharedSupport".
  6. Delete the file named "InstallInfo.plist".
  7. Enter your administer password to confirm.
  8. Now open the installer.

After deleting InstallInfo.plist, the installer runs. When it gets ready to restart, I get the error message:

"An error occurred while preparing the installation. Try running this application again." (see screenshot) Screen shot of An error occurred while preparing the installation. Try running this application again.

Searching for this error online suggests it can be linked to a mismatch between the system time and the time server, but my computer has the correct time and is set to update the time automatically.

I am currently running:

  • OS X El Capitan version 10.11.6. (Note that I was also not able to upgrade to Sierra 10.12, with similar errors)
  • MacBook Pro (Retina, 13-inch, Early 2015)
  • Processor 3.1 GHz Intel Core i7
  • Memory 8 GB 1867 MHz DDR3
  • Thanks for the posts below -- I appreciate the time you all have put into this. I should have mentioned that I did try deleting and re-downloading from the App Store before posting this. – Sasc Oct 4 '17 at 2:32
1

I had the same problem with an iMac,

just delete the update program from your mac and re download it from the App Store.

If that won't work you should make a Backup with Timemachine and reset your Mac. Try to update again. if it works, recover your data from the backup.

Check this link if you need help with the reset of your system. https://support.apple.com/kb/PH25649?locale=de_DE&viewlocale=de_DE

  • Fortunately I can read German ;-) – Sasc Oct 4 '17 at 2:33
1

Remove the updater to High Sierra and download it again from App Store, this should solve the issue. Also, be sure to check Safari settings, the update might not work well with it when you get Safari 11.

  • Which settings should I check in Safari? Or, did you mean that I should download the update using a browser other than Safari 11? – Sasc Oct 4 '17 at 2:34
1

As suggested by user275752 in this thread, setting the date and time using the terminal app from the installer (Utilities → Terminal) as follows:

date 020914552018

solved this problem for me. Details on why this may solve the issue can be can be found in a comment by NSGod in a similar post about el capitan:

What's happening here is likely that the installer is trying to check its code signature, which involves checking the validity of all the certificates in the certificate chain. All certificates have an expiration date, and the application itself is likely signed with a certificate that has since expired. By setting the date to a date in the past you'll allow the certificate check to complete successfully.

As highlighted by Riley in the comments below, the format of the argument to the date command is [[[[[cc]yy]mm]dd]hh]mm[.ss]. Further details on the date command can be found here.

  • This worked for me. Thank you! "date is in the [mm][dd]HH]MM[yy] format, which is Month Date Hour Minute Year without any separation" – Riley Jul 9 '18 at 7:42
0

From macOS Utilities or OS X Utilities screen, select Terminal

Type in the command ntpdate -u time.apple.com to update your time server.

If you have no available internet connection, set the date of the machine to the current time.

You can do this by typing in something like:

date 020914552018

The first two digits are the month. The next two digits are the day. The next 4 digits is the time in 24-hour format. The last 4 digits is the year.

date mmddttttyyyy

Where mm = 02
Where dd = 09
Where tttt = 1455
Where yyyy = 2018

Obviously this code is taken by the original example posted, but it should reflect the current time, date, year.

I am not sure why this is, but I believe it's becuase macOS and OS X have a built in protection to ensure it's being installed post production, so it's not a hacked version of macOS or OS X.

I have tested this on Sierra, High Sierra and Mojave on VM's and physical hardware.

Usually when a machine is offline for a while this occurs.

There is another way to update the date/time automatically by connecting it to an internet connection and using this command:

ntpdate -u time.apple.com

Once you've done this, typing in the command date will show you the time the system is updated to reflect.

You can then quit Terminal by typing exit then using Command+Q and continuing with the installation per usual

Happy days!

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • How does one do that? It's helpful if you not only say what, but how as well. – Allan Feb 9 '18 at 21:00
  • Not to mention why does this solve the issue posed? – Jonathan van Clute Feb 10 '18 at 3:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .