7

After downloading the new macOS for my MacBook pro (mid-2012) with HDD, the computer restarted but continues to fail during the installation. The error I keep getting is com.apple.DiskManagement error 0. I completed a disk repair but no errors popped up there, so I assume nothing is wrong with the drive. I tried to reinstall macOS from recovery mode, but I continue getting this same error. Does anybody know how to fix this problem?

  • I am having this issue too!! Anyone else have any success getting it to work? – Amy Sep 27 '17 at 2:36
  • I had the same issue installing the GM last week. After a couple of days trying to fix I gave up and rolled back to Sierra to wait for the "final" version (I guess the GM became the final version). – lpacheco Sep 27 '17 at 4:50
1

yes, i had the same problem with a macbookpro8.2 early 2011. i finally installed it with a bootable usbstick. And i formated the ssd with the old os. here is a workaround from apple https://support.apple.com/en-us/HT201372

  • Has there been any explanation why this happens? If I create a disk image from Disk Utility before reformatting the drive, will I be able to restore those files and settings to High Sierra later on? Also my Mac Pro uses a HDD, not SSD -- which means I'm unable to use the new Apple File System. – wellington Sep 27 '17 at 1:51
  • 1. you need good skillz and the migration assistant, to transfare your apps from an ol os to the new one. Didn’t work in my case,2. the APFS is not supported for non flashdrives. 3. you can make a backup with timemaschine, filevault and if you only need the files, just dragdrop the complete system on an external drive and you are save, but i would not uprgade again, maybe you perfomance is much better with an older os like 10.8 or 10.9. – Marco Doll Sep 27 '17 at 8:36
  • I don’t care so much about the apps, but I would like to have my files. Is it possible to open the image file (located on external drive) and drag/drop the files, just like files on a flash drive, after new OS is installed? – wellington Sep 29 '17 at 1:57
  • that depends on the image typ, but what is the main thing you want to do? you have a old hdd with data right? you want to browse you old files? – Marco Doll Oct 1 '17 at 21:45
1

Ok here is how I fixed it,

  1. Start in recovery with ALT+CMD+R
  2. Go to disk utility
  3. Convert the volume to APFS
  4. Restart the installation

The install was really slow like 2/3h but in the end it worked without anything lost.

  • ALT+CMD+R is used to start internet recovery, which might not be available on a 2012 MBP – Jules Sep 28 '17 at 7:27
0

I had the same issue. It was two long days for me, but the solution was always there.

  1. You have to go to internet recovery mode with Alt + CMD + Shift + R (all of them).
  2. You reinstall the OS that came with your Mac (you won't lose your data)
  3. After you have installed the OS, delete everything related to the previous install (I had to go to the root folder and delete and installation folder)
  4. Download again Mac OS High Sierra and continue with the steps for the installation.

It took a couple of hours (I have a 10 mb bandwidth connection)

Hope it will help for some of you.

  • I reinstalled the original OS using this method. After downloading High Sierra again, my Mac doesn’t restart to begin the installation process. It says High Sierra is installed, but there is not request to reboot. This has been such a pain. Apple is falling apart before our eyes. – wellington Oct 2 '17 at 3:45
  • To fix the restart issue I had to delete the “install macOS High Sierra” app from the Applications folder. After that, I downloaded HS from the App Store. Once again, my Mac restarted, began the installation process, and stopped halfway through saying it could not be installed, please restart. Apparently it doesn’t matter which OS I am using, Sierra or Mountain Lion, to install HS. At this point, I’m really not sure what to do other than creating a bootable drive of Sierra and saying the heck with High Sierra. – wellington Oct 2 '17 at 19:39

You must log in to answer this question.

protected by Community Oct 2 '17 at 9:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .