2

Did you succeed in installing LilyPond on Lion? How?

After downloading the (precompiled) LilyPond, I am getting: Lilypond-error

In plain text:

LilyPond Error

An unexpected error has occurred during execution of the main script

ImportError: dlopen(/Applications/LilyPond.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so, 2): Symbol not found: _objc_sync_notify

Referenced from: /Applications/LilyPond.app/Contents/Resources/lib/python2.6/lib-dynload/objc/_objc.so Expected in: /usr/lib/libobjc.A.dylib

And yet I duly have:

ls -l /usr/lib/libobjc*

-rwxr-xr-x 1 root wheel 1997152 21 Jul 01:27 /usr/lib/libobjc.A.dylib

lrwxr-xr-x 1 root wheel 15 21 Jul 01:28 /usr/lib/libobjc.dylib -> libobjc.A.dylib

  • The problem is not that the file is not there, it is that a "symbol" (code entry point) is no longer there. – Jason Salaz Nov 2 '11 at 19:31
  • I have not successfully gotten LilyPond to run on Lion. – Daniel Nov 2 '11 at 20:01
  • 1
    @Daniel: I wish they wouldn't just write "for OS X 10.4 and above". It's a little bit too optimistic. – Calaf Nov 2 '11 at 20:18
  • @JasonSalaz ..So I guess I should have written otool -X /usr/lib/libobjc.A.dylib . Except that none of the switches I tried in the place of -X would reveal the symbols in a dylib. Anyway, I don't doubt that the symbol in question is indeed missing. – Calaf Nov 2 '11 at 20:20
2

The problem is solved in the development version, download from LilyPond Development Page and use at own risk.

  • Indeed, LilyPond 2.15.16 works fine on Lion. And it is already compiled, despite being from the development branch. – Calaf Nov 3 '11 at 3:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .