5

My mid-2011 iMac was running OS X Mavericks for years, and I decided over the weekend that it was time to see about upgrading to Sierra (not High Sierra). So I cloned my boot drive to another partition, and upgraded to Sierra on it. For the most part everything is fine, but there's an issue with Mail.app that is really frustrating me.

In Mail I have rules, based on the send address from different people/places, that move those emails into specific folders (mailboxes, in Mail terminology). For instance emails from my bank go into my "Finance" mailbox.

Then I have a separate smart mailbox labeled "Finance" with a single rule - "Messages is in mailbox 'Finance'". This allows me to organize all my different frequently used mailboxes into one area "Smart Mailboxes" which I can move to the top of the sidebar for ease of access.

In Mavericks, this works great and I have a couple of mailboxes set up this same way. But in Sierra, this doesn't work at all. The rules work fine for moving the emails into the separate folder/mailbox, but the smart mailbox rule fails to save. I can set it as desired, but on subsequent editing it will always read "Message is in mailbox 'No mailbox selected'" and therefore will show me all emails in my inbox, rather than just those in the Finance mailbox.

The issue appears to only be with using mailboxes that are in my iCloud account. I can select a folder in a Gmail or self-hosted mailbox for example, and the Smart Mailbox rule works fine.

Why does this work fine in Mavericks but not Sierra, and how can I get it to work once more? I have already tried a Rebuild but it did nothing.

  • So while I don't have an answer to my question, I have decided the only solution is to bypass the "rules" entirely and just define them directly in the smart mailbox, rather than in preferences. This works as expected. – Jonathan van Clute Sep 28 '17 at 13:56
  • After living with this "solution" for over a week, it's terrible. It means my messages don't also physically move into the desired folder, unless I maintain two sets of identical rules - one in the smart mailbox itself, and one in preferences. This should work, and used to work. Does nobody else run into this issue? – Jonathan van Clute Oct 10 '17 at 3:19
  • 1
    May be related to this issue: Smart Mailbox filter "Message is not in mailbox" for iCloud mailboxes. Unfortunately no answer there either. – Greg R. Oct 31 '17 at 12:19
  • Oh wow, OK so at least I'm not the only one, thanks for finding that! – Jonathan van Clute Oct 31 '17 at 16:29
  • So you don't see the problem described in this question? It's driving me absolutely crazy every single day. – Jonathan van Clute Nov 13 '17 at 0:42
1

OK, I can't explain why this happened, but this issue appears to be fixed. I was trying to resolve a different issue (Gmail emails going to Recovered Messages for unknown reasons), so I deleted my Gmail account from the Internet Accounts in System Preferences. Then I quit & relaunched Mail, and in Mail Prefs I added the GMail account back again.

Suddenly, both the Gmail problem I was trying to solve, AND this Smart Mailboxes issue, were fixed! I don't know what the actual problem was, but for whatever reason this appears to have solved it. I'll accept the answer after I've lived with this a day or two and it stays fixed. So weird...

  • So this solved the problem until today, when due to an unrelated issue I had to sign out and back into iCloud. As soon as I did that, I once again lost my smart mailboxes! This time however, rather than delete the gmail account, I simply de-selected Mail from it. Immediately, the smart mailboxes reappeared. I re-enabled the Gmail account once more, and all is fine. This is soooo weird. – Jonathan van Clute Feb 9 '18 at 4:31
  • I stand corrected - this morning my smart folders were gone again. Disable the gmail account in Internet Accounts, and they came back again instantly. But somehow... gmail is preventing Smart Folders from using a folder that's in an iCloud account. I don't get this at all, incredibly frustrating. – Jonathan van Clute Feb 9 '18 at 16:47
0

I had a similar problem and I found a solution here luckily after searching like crazy. The problem was, that I used my Gmail account as my Apple Id, so mail got confused. After I deactivated mail in my iCloud account settings, it was working fine. This is obviously only a solution if you don't use both accounts. Anyway, maybe it helps someone:

And here's the solution, or rather the explanation for the problem: If you're using your gmail Adress as your apple-id (and therefore as your login credentials for your iCloud account) Apple Mail seems to get confused. Simply change your iCloud Username to something else and your good to go.

  • Holy crap seriously? I am indeed using my Gmail address as my iCloud ID. I didn’t even realize it was possible to change your iCloud ID… I will have to look into this. Thanks! – Jonathan van Clute Jun 1 at 0:29
  • OK I changed my apple ID to use my .me account instead of my gmail. I logged out of iCloud on all my devices first except for the laptop where I was making the change. Now all those other devices are logged back in with the new ID and they show that as the ID. But my laptop shows my gmail as my ID, even when I log in successfully with the new ID instead. Also my mail Smart Folders now don't work again. WTF Apple. This sucks. – Jonathan van Clute Jun 1 at 1:12
  • So I used my previous "trick" of disabling and re-enabling gmail in the Mail.app preferences. Seems to have worked and my Smart Folders are working again. For now anyway. Hoping this time they stick! – Jonathan van Clute Jun 1 at 2:24
  • Nope, didn't stick. Still won't allow me to select the mailbox from iCloud, even though my Apple ID is no longer my GMail address. Infuriating. – Jonathan van Clute Jun 1 at 17:31
  • Too bad that it didn’t work for you. I was just disabling my iCloud Mail Account and it works (for now). Those things can drive one crazy, I know. And even thinking for how long this problem exists... I mean we have Mojave now... – Steven Jun 3 at 0:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .