5

I just upgraded to macOS High Sierra and now I am not able to login using network account. However, I am able to unlock the FileVault2 volume using the old credentials but then it asks for credentials again. On login screen, I see a red dot beside username saying network accounts are unavailable

I have two accounts on my machine. One network account with admin privileges and a local account with standard privileges. I am able to login using local account but not with the network account.

I have FileVault recovery keys, will it help?

I am using MacBook Pro mid 2015 series.

  • 1
    I was in the same situation, IT needed to rebind the AD in my macbook using the admin account – amertkara Sep 26 '17 at 21:06
  • Yes, our IT team also rebind AD in my macbook and now it is working fine. – banjara Sep 27 '17 at 5:08
  • @banjara Please make your comment a proper answer! Please include all steps how to rebind a High Sierra Mac with FileVault enabled. You may have to ask your IT team what they did. – klanomath Oct 2 '17 at 12:29
3

You will still need local and Active Directory administrator account for this to work, but here's the exact steps I took to fix this issue.

  1. Login with local administrator account
  2. Go to System Preferences > Users & Groups
  3. Press Login Options > Unlock > Press Edit near Network Account Server > Open Directory Utility > Unlock > Select Active Directory and press "Edit settings for the selected service" button at the bottom > Unbind > Enter Active Directory administrator credentials and finish the unbinding process
  4. Close Directory Utility and reboot the computer
  5. Repeat steps 1 and 2
  6. Press Join near Network Account Server
  7. Enter your domain (ad.example.com) and Active Directory administrator credentials.

Assuming your AD account is not entirely network account (created on your local system and you can use it without network access) you should also set settings in 8-10 steps.

  1. Optional Step - Go to System Preferences > Users & Groups
  2. Optional Step - Login Options > Unlock > Press Edit on Network Account Server > Open Directory Utility > Unlock > Select Active Directory and press "Edit settings for the selected service" button at the bottom
  3. Optional Step - Press Show more > Check "Create mobile login at login" > Uncheck "Require confirmation before creating a mobile account"
  4. Log out (may need another reboot)
  5. Login with network account by selecting the user from the list or using your name on password (depends on "Display login windows as" setting)
0

This is how I fix it https://github.com/onmyway133/blog/issues/86

Today I met a strange problem. After I enter my password, the progress bar runs to the end, and it is stuck there forever. No matter how many times I try to restart.

I finally need to go to Recovery mode by pressing Cmd+R at start up. I then select Get Help Online to open Safari. Strangely enough I wasn't connected to Internet

After select the wifi icon on the status bar to connect internet, I then restart and can login again. It seems that macOS is checking for something before allowing user to login

0

It appears that the main issue is in the empty local cache of network accounts after upgrade to High Sierra. I was able to login to network account without re-binding to network directory using the following steps (simplified comparing to @ernestasen's answer):

  1. Login with local administrator account
  2. Go to System Preferences > Users & Groups, Click the lock to make changes, Press Login Options, Click on Options button next to Allow network users to log in at login window
  3. Select Only these network users:, Press the plus sign
  4. Wait until network accounts are populated in the Network Users section (in my case I had to wait about 20 seconds while the accounts were showing up on the screen)

That's it, now you've got a local cache of network users refreshed, so you can press Cancel and restore desired option that was changed on 3rd step.

0

I love the answer by earnestasen and wish I had thought of that. I did yet a third thing to solve this. I logged in as a local admin, created a new local account, logged in to that account, connected to AD subnet (since I’m remote) via the VPN (which took some doing to get my VPN profile in this temp’ user account), then once connected, I did fast user switching to my domain account, and it worked. I rebooted to test it and was able to log straight in again afterward. I was momnetarily panicked that I’d orphaned my account, or would need to fly to SFO to be on the LAN for all of 3 minutes to solve this, but in the end was able to solve this with only a couple hours of downtime. I then removed the temp’ user and am whole again. Cheers.

0

The solution is simple, IF you have another user account set up. I had, for my girl friend.

  • Login with the other account
  • Go to apple> utilities> terminal;
  • Enter resetpassword;
  • Follow the instructions on the screen.

You may have to reenter some app passwords to store in your keychain again

0

The solution which worked for me...

System Preferences
Users & Groups
Click the padlock and enter the admin password
Login Options
Edit the Network Account Server to open the Directory Utility
Click the padlock and enter the admin password (again...)
Select Active Directory and click the pencil to edit
Enter the admin password (again...!)
Click the drop-down arrow by "Show options"
Select the Administrative 'tab'
Ensure the "Prefer this domain server:" and "Allow administration by:" options are ticked. Add the relevant user into the list for admin rights.

enter image description here

OK everything and reboot.

Not sure why the OS upgrade from Sierra to Mojave would have de-selected these options but there you go.

You must log in to answer this question.

protected by Community Nov 23 '17 at 17:18

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .