Got the following error

The path /System/Installation/Packages/OSInstall.mpkg appears to be missing or damaged

while upgrading Mac Mini (Late 2012) to High Sierra. The only option on the screen is to restart, after which the same error pops up. Tried some suggestions from google search and none of it is working

  • Tried booting to recovery and using disk utility to repair/firstaid but disk utility is struck in discovering state spinner for one hour
  • Using terminal in recovery mode to check the disk and repair permissions and SMART status all are reported fine
  • Tried diagnostics and it reported all good
  • Internet recovery stuck at globe 3:30 remaining time for past 5 hours
  • Tried booting to safe mode which is stuck at apple logo for past 7 hours

What is the next setup in this case, I have Time Machine backup but it was 1 week old and there are some important unbacked files that I cannot afford to lose

  • Can you boot another Mac in target disc mode to recover the important files? Then you could just restore the time machine backup. Alternately, you could look into creating a live Linux USB to get the files off that way. – Wowfunhappy Sep 27 '17 at 21:11
  • Could you solve it? I get the same error message when trying to do a clean installation of High Sierra from an USB. The answers in this thread couldn‘t solve it for me. – Marvin Sep 28 '17 at 8:18
  • @MarvinF yeah, I created a bootable usb and installed from there, and no data loss – reku Sep 28 '17 at 8:23
  • 8
    After that window appear, click its window (don't click Restart button). Then the menu bar will appear, click the apple logo, select Start Up disk, select the Macintosh HD (don't select Installer) – Michael Buen Dec 15 '17 at 5:15
  • 1
    You can hold option key (alt) on starting mac and then choose your disk drive instead of startup disk. After start mac you will be able to download update again. – Arkadiusz Wieczorek Dec 20 '17 at 7:56

13 Answers 13

Same error happened to me when I received an update from 10.13.1 to 10.13.2.

If you boot with shift button pressed, you will be able to enter safe mode and try to download and reinstall an update. It did not help to me so I booted holding Option key and chosen regular Mac HD (not an update volume). Booted to my Mac without safe mode and tried to reinstall this update. Somehow it worked out in several reboots.

  • 5
    Using the Option key to boot worked for me. – Fred B Jan 12 at 0:17
  • 2
    Holding the shift key allow me to enter the GUI but there's no network connection available. Given up after trying a while. Holding the option key shows OS installer and Recovery, but not Macintosh HD. Tried OS installer and ended up the same error. Try again with Recovery, then choose restart from the top menu. This time the Macintosh HD is shown and I'm able to boot normally. – Lacek Mar 5 at 2:21
  • worked for me, thank you! – dprogramz May 28 at 21:13

The easiest solution is the one by commenter Michael Buen. It has worked on 20 Macs I've seen have this issue.

Apple Menu -> Select Startup Disk -> Restart (after clicking your boot drive) resolves the issue, at least temporarily. This can be done at the error screen, by clicking on some empty space in the grey message box to get the apple menu bar to appear. You can also get to this "Select Startup Disk" menu option by starting up the Mac in recovery mode (cmd+r) or internet recovery (cmd+optn+r). If you use FileVault encryption, you'll need to enter your user password to unlock the drive.

Re-installing MacOS on top if itself also solves the problem, but takes more time. Internet Recovery (cmd+optn+r) and a MacOS bootable USB installer disk both work and in theory do not delete any personal data.

I've seen it recur more than once on the same computer. Updating to the latest point update for High Sierra (10.3.3 Supplemental) might be advisable, but does not guarantee a resolution.

  • I’ve also had this happen multiple times on one of my laptops. Restarting, then holding down Option lets you choose the system volume instead of the installer. In this latest case, I was trying to update to 10.13.3, so I just went into the App Store and started the process over again. – Bryan Scott Mar 10 at 15:07

This is what worked for me, based off of this post: https://medium.com/@aeronode/how-i-fixed-my-non-booting-macos-high-sierra-installation-45d238b78c3d

Restart in recovery mode (Cmd-R), Utilities -> Terminal

find / -name OSInstall.mpkg # Will be found somewhere in a tmp directory
mkdir -p "/Volumes/Macintosh HD/System/Installation/Packages"
cp "<OSInstall.mpkg path>" "/Volumes/Macintosh HD/System/Installation/Packages/"
reboot
  • this says read only file system – Abhishek Mitra Nov 3 '17 at 14:52
  • This works. If find fails or you don't want to search a lot. It is possible to dig the mpkg out of the installation medium (for instance on another computer). – andy Nov 4 '17 at 22:55

I had the same error - turned out to be a disk space error. Opened up terminal from the recovery screen where it was asking me to reboot and cleared out several gigs of VMs and it worked after a reboot. I went ~15GB of free space to around 50GB, hope that helps someone else!

  • It seems that the new OS requires more disk spaces that it expects – code4j Oct 12 '17 at 20:24
up vote 5 down vote accepted

Here is how I solved this

Before trying anything first backup data using terminal in recovery mode. Once you are safe even to lose data, then follow these steps

  1. create bootable usb as mentioned in this link https://blog.hqcodeshop.fi/archives/232-OS-X-Yosemite-upgrade-from-USB-stick.html
  2. Select Install or upgrade macOS from booting the usb
  3. After four hours of suspense, I was greeted with my account and all data is intact

During installation it was unclear if mac is updating or installing fresh but somehow it worked and disk format is same as old Mac OS Extended (Journaled)

I had this problem installing the latest macOS update. I tried a few things, but in the end the resolution was pretty easy.

  • Boot up your Mac using Cmd + R to access the recovery partition
  • In the Apple menu choose Startup Disk
  • Select your HD and I believe there was a button to unlock the drive. Input your password and the drive will be unlocked.
  • Reboot your Mac and it should boot right up

I know @Cloneman's solution was essentially the same idea, but this ended up being a little more straightforward as I wasn't able to get the menu to show up in the upgrade error screen.

This install actually crashed my HD. I hadn't noticed that the drive was nearly full before the update started, but during the install process the HD maxed out and then became unmoutable or mountable, and not recognized. Fortunately it was backed up but there should be a check on available disk capacity before starting the install process. In any event, here was my fix:

Start the Mac in recovery mode - Command-Option-R

Open Terminal

Get a list of volumes by:

$ diskutil list

Note the HD reference (mine was disk0s2)

kill fsck:

$ ps -ax | grep fsck    (to get the process number)  
$ kill 

Erase the volume

$ diskutil eraseVolume JHFS+ MyVolumeName /dev/disk0s2

Then install the update as a new install

  • Killing fsck was key. I was then able to mount the drive with: “diskutil mount disk17” and then was able to remove some files from the drive. – Jason Moore Dec 5 '17 at 16:08
  • This will erase all the files, right? – coderodde Mar 5 at 19:10
  • Agree with @JasonMoore - killing fsck did the trick, at which point you can mount the drive and do whatever cleanup needed. No need to actually erase the volume. – zeroimpl Apr 7 at 5:15

For some reason the disk my Mac was booting from was the macOS Installer Disk, all I had to do: Hold down the option (-alt) key before the Apple logo shows. Then just select your Macintosh HD (or how you named the volume when you installed macOS).

This weird boot thing happened after I ran an update on High Sierra.
If this doesn't resolve the issue, you could try the chosen answer.

It could be that your problem the problems on your Mac are worse. Then I would suggest to backup all your data in safe mode (or from a terminal in recovery mode) and do a clean install of macOS from a USB stick or from internet recovery.

Encountered the same error. Created an ISO image of the OS High Sierra on USB and did the installation successfully.

I got into the same problem and it was extreme frustrating as no matter how many time I download, it could not just boot up. So how I solved my problem and install Mac High Sierra? Well what you need to do is to create a bootable usb then install the Mac High Sierra on the disk. That way you will have clean copy of Mac OS.

I have faced up the issue yesterday, the solution was the same above, that was:

  1. Mount High Sierra's install
  2. Check /Volume/InstallESD/Packages/ to find OSInstall.mpkg
  3. cp "<OSInstall.mpkg path>" "/Volumes/Macintosh HD/System/Installation/Packages/"
  4. Reboot
  • 3
    How do you mount High Sierra's install? I don't see any .dmg files anywhere when I boot into recovery mode (even in /Install macOS High Sierra.app/Contents/...) – wryfi Oct 20 '17 at 16:28

First boot to the recovery partition open terminal and type csrutil disable, then restart your Mac and hold CMD+S till you see plain text. Now plug in another pendrive and then press enter. Now find the pen drive disk identifier by typing ls -la /Dev/disk*. Then type mkdir usb. Then type mount - t [filesystem of pendrive] /Dev/diskX /usb. Then hit enter then type rsync -p -o [path to the file you want to backup] /usb
Tip: You can find the files listed in a specific directory by typing ls -la [path to directory]
Eg.ls -la /Users/home-directoryname/Desktop

After the process is complete you can check if the files are there on your pendrive by typing ls -la /usb

Then type reboot Then once you hear the startup chime hold CMD+R then open terminal and type csrutil enable

The CommandOptionR Operation (Internet Recovery Mode) seems to have worked for me. I chose to reinstall OS High Sierra on my mini mac, my MacBook Pro non Retina late 2012 as well as my MacBook Air and the upgrade completed without any issues...

protected by Community Feb 7 at 3:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.