2

After upgrading Aquamacs to version 3.3, many modes turned on auto-fill-mode. I've followed the answers from questions such as "How can I disable auto-fill mode in emacs?" to disable it, but without complete success. Specifically, I:

  • set line-wrapping option to "Wrap" (Options→Line Wrapping→Wrap)
  • turned off "Auto-Detect Line Wrap in Text Files"
  • set line-wrapping options as default (Options→Line Wrapping→Adopt as Default)
  • saved options
  • added lines to .emacs to disable mode globally:

    (auto-fill-mode -1)
    (remove-hook 'text-mode-hook 'auto-detect-wrap)
    
  • added (auto-fill-mode nil) to hooks for specific modes (e.g. html-mode, nxhtml-mode, xhtml-mode).
  • set text mode hook in customizations.el to disable auto-fill-mode:

    '(text-mode-hook
      '((lambda nil (auto-fill-mode nil))
        smart-spacing-mode))
    

Despite these changes, auto-fill-mode is enabled for some newly opened files (e.g. txt, html, svg) in Aquamacs (the system emacs also enables auto-fill-mode when entering html-mode, but not text-mode). I've grepped for auto-fill in the load path directories that exist but haven't found anything that appears to be enabling it:

  • ~/Library/Application Support/Aquamacs Emacs/
  • ~/Library/Application Support/Emacs/
  • ~/Library/Preferences/Aquamacs/
  • /Applications/Aquamacs.app/Contents/Resources/lisp
  • /Library/Application Support/Aquamacs Emacs
  • /usr/share/emacs/site-lisp

Where else might auto-fill-mode be enabled? How can I fully disable auto-fill-mode?

-2

Add this to ~/Library/Preferences/Aquamacs Emacs/Preferences.el:

(remove-hook 'text-mode-hook 'auto-detect-wrap)
  • Did you read the question? – Chill2Macht Mar 5 '18 at 18:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .