5

I updated my late-2013 MacBook Pro from macOS Sierra to macOS High Sierra this morning. The update ran fine and I got back into my system everything looking ok.

Then I shut the MacBook down to go to work. When I tried to boot it up again I end up with a black screen and nothing to happen further. (In detail: The screen turns on (apple on back is bright). I hear the boot up sound. Then nothing happens. The screen stays turned on even if I remove power and close the lid. Only pressing power button for a view seconds turns the MacBook completely off. Another interesting thing: when I let the MacBook stay in this black screen state for a while I start hearing the cooling ventilator running at low power which suggests that the MacBook is making use of its computational power but does not display anything)

Any ideas what to do now? (of course I have a Time Machine backup on an external drive but I don't have an idea how to make use of it at this point)

Further information:

  • The macOS partition was encrypted with FileVault and a modification: only he root user can decrypt it

  • Also there was a Boot Camp partition with Windows 10

  • It seems like pressing Option key works and booting the Windows partition works!

  • When I press the Option key I can select between Windows and Macintosh HD. Menu works fine. The second I press Enter on the Macintosh HD it seems to freeze. So maybe it's related to the encryption?

  • I managed to boot into my time machine backup using the boot menu with connected backup drive. Using the Disk Utility I found a crazy fact: It seems like the macOS partition is gone. Not sure if this is normal (could be because Disk Utility can't read the encrypted partition?)

    macOS partition is gone. There is only a "untitled" left where it should be

  • We’re having these issues on 2014 mbp’s... I think it is related to FileVault. – y3sh Sep 26 '17 at 13:07
  • Same — I thought it was odd that file vault said that the root user is not enabled to access the main partition in the security pref pane... but restarted anyways. – Jack Wade Sep 26 '17 at 13:15
  • After unlocking the volume with the FileVault recovery key, I ran first aid on the drive and found that the fsroot is invalid. error: invalid dstream.default_crypto_id, invalid dstream, invalid xfields, fsroot tree is invalid. We've gone the TM restore route for now. – y3sh Sep 26 '17 at 15:54
1

Possible reason for the problem

I am not 100% sure but my guess on why all this happened is the special way I set up my disk encryption. (For detail: I used normal File Fault encryption but because my standard user has a weak password I removed this user from the users who are able to decrypt and instead added a root user with a strong password who was able to decrypt the drive.)

As my research provided the the update to High Sierra changes the file system format from HPFS+ to the new standard called APFS. With a different encryption as well. My guess is that during the upgrade either the special root user was removed or another error occurred in connection to this constellation.

How I finally dealt with it

As written above I was able to boot in the recovery mode of the TimeMachine disk. But I had to realise that this time machine was running OSX El Capitan (obviously the running system of my Mac when I created the first backup) and El Capitan was of course not able to either decrypt or even identify the new APFS file system on my internal drive (which explains the missing partition in my picture).

The next try was (don't know why I didn't try this earlier) to boot in normal recovery mode by holding down CMD+R while booting. This worked and I was able to use the disk utility to delete the Macintosh HD partition, create a new one instead (as APFS) and the reinstall macOS High Sierra from the recovery menu.

After the complete new installation finished I was asked if I want to move any data and I selected my Time Machine backup. It needed a few hours but after this my system is back on track. Everything seems and where I left it.

Notes

  • As general note for all of you who want to perform the upgrade: Back up your data immediately before doing it!

  • And after the update is done shut down the Mac once to check if everything is fine. (Don't wanna think about the scenario where I would have worked a few days without shutdown any new backup and then shut it down to end with this...)

  • After my described fix I had to set up the disk encryption again (now I only use my normal user and instead of any trick the account now has a strong password...)

Thanks for your help :)

0

You can try this:

Click partition, select "Untitled", then repartition it as a HFS+(Mac OS Journaled) drive. If you succeed, you'll be able to restore from your Time Machine backup by opening the restore app from the front page of recovery mode.

  • Really hoping this isn’t the solution. – y3sh Sep 26 '17 at 13:08
  • @y3sh "Kappa" writes in his/her post that he/she do have a Time Machine backup, so it won't be a terrible solution... – Harcker Sep 26 '17 at 13:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .