5

I just created a USB Installer for High Sierra and tried to install my Mac Pro 4.1 (flashed to 5.1).

But the installer wants to do a Firmware Update too and says I have to shutdown and press the power button until the EFI beeps. But this Shutdown button in the installer is greyed out so I can't proceed.

Any help?

3

I found this on MacRumors...

Yeah you get a firmware update! :eek: first time the 5,1 has gotten a firmware update in ages! I did not get it when updating from DP1 to DP5 but if you make a DP5 installer, it says you must update your boot rom before you can install and it tells you how, the shut down button did not work for me but going to the apple menu and hitting shut down worked for me :) then i followed the normal hold power button until flashing power light and bam it did the firmware update! and im using a flashed 4,1 to 5,1 Mac Pro! so yeah looks like flashed 4,1s are so identicial they happily take the High sierra boot rom update! :D

So it looks like you'll be OK if you manually shut down, then follow the 'hold until it flashes' instruction after that.

Reading further down that thread -

Just a heads up to update the firmware on a Mac Pro 4,1 or 5,1 you have to install an EFI video card (this is true also if your flashing a 4,1 to a 5,1) if you dont have a EFI video card then it won't update

Note: I gave up after about 6 pages of that thread, but the general consensus seems to be the above instructions do work.

Let us know how it goes - I have a similar machine...

Update April 2018
I just attempted this myself [eventually]. I first stripped all except the boot drive [Samsung SSD in the optical bay] & keyboard/mouse. Successfully got the Restart button to work, no probs, but the firmware update didn't succeed after holding the button until the light flashed.
After a bit of Googling, I found a note that said to hold the button not only until the light flashes, but keep holding until you hear the beep tone. After doing that, it worked & all went smoothly after that. The OS update is actually a separate process, which I hadn't realised until that point.

  • Humm, thank you for your answer. I tried the manual shutdown in the Apple Menu, pressed the button until the beep but then the Mac Pro just starts booting from the USB Stick again and doesn't do the Update... – Francis Sep 26 '17 at 7:27
  • You have an EFI video card? Did you check the actual firmware version afterwards? – Tetsujin Sep 26 '17 at 7:31
  • 1
    I have the standard GT120 my Mac was shipped with. The installer always wants me to upgrade the firmware and the EFI loading bar doesn't appear. – Francis Sep 26 '17 at 9:23
  • 1
    please see my answer how I was able to manage it. – Francis Sep 26 '17 at 14:08
  • Why does it require the EFI video card to be installed? Is there something interactive or is the software just being obtuse? – bjb Sep 26 '17 at 16:47
2

Okay, I got it.

First, I installed Sierra an a USB drive and did all updates.

Then I inserted the High Sierra USB drive and started the installer. And voila, I was able to press the shutdown button and did the EFI update!

  • Did you install the High Sierra standalone bootable installer onto the USB drive, or did you run the High Sierra installer application while in Sierra? If it's the former, I don't see what Sierra updates have to do with anything. – sudo Dec 21 '17 at 18:41
1

I noticed my EFI partition wouldn't mount using bless and figured it had somehow been corrupted (gave the "invalid sector size" error during mount), thus preventing the firmware update from happening. Also tried some random other tools involving the EFI were failing.

Besides the prerequisites I already had (standard Apple-branded GPU, etc), I had to freshly reinstall Sierra onto a separate physical disk then run the HS installer to update the firmware. Tried a separate partition too, but that didn't work because as I suspected, there's only one EFI partition per disk.

0

have 2009 4.1 which was already updated to 5.1 and running Sierra. Downloaded High Sierra and had some problems as High Sierra install just stopped about half way through but manually powered down and restarted and it resumed and completed OK. Now running 10.13. Stay with it and you will get it done.

  • Just flashed from 4,1 El Capitan 10.11.6 to 5,1 El Capitan 10.11.6, and updated to High Sierra 10.13.6 with no issues. In case anyone runs into this questions in the near future. – FossilizedCarlos Sep 14 '18 at 4:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .