I want to make a USB media installer for the new High Sierra release. I commonly use createinstallmedia or DiskMakerX but for this new release I just can't make it work (both). I downloaded the Install macOS High Sierra.app from the App Store but the installer is only 14.2mb so it doesn't contain the High Sierra image. I started the installer and that starts the download but all the downloaded files are stored in ./macOS Install Data and I want to make a USB media installer with those files. Any idea of how to solve this?

Also in createinstallmedia i'm using this command:

sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/macOS --applicationpath  /Applications/Install\ macOS\ High\ Sierra.app --nointeraction

and i'm getting:

/Applications/Install macOS High Sierra.app does not appear to be a valid OS installer application.


App size

Download folder

7 Answers 7


Massive bump to @IlyaB, I was stumped trying to get the full 5gb Install MacOS High Sierra.app but was stuck with the 19mb stub version.

My Process to get a working app that is currently making my bootable USB for High Sierra

1: Go to Mac App Store and download High Sierra (the 19mb stub)

2: Click Continue in the installer app once it downloads

3: Choose your boot disk (or any disk that has space)

4: Allow the installer to download (this is the contents of the missing "SharedSupport" folder within the installer stub)

5: The installer will prompt you to restart after finishing the 5gb download, at this point quit the installer and do not restart your system!

6: Go to your root (or whichever location you chose in step 3) and find the folder "macOS Install Data"

7: Copy the contents of that folder disregarding .DS_Store attached image

(9 files, folders, dmgs, pkgs, and plists)

8: Go to your Applications folder where the Mac App Store downloaded the stub version of "Install macOS High Sierra"

9: Right Click on that file and "Show Package Contents"

10: Within the Contents folder, create a new folder called "SharedSupport"

11: Paste the files you copied earlier from the installer download

12: And you're done! You should have a fully functional Installer file for bootable USB drives or just copying to other systems whether they be offline, or you just don't want to download the installer over and over.

I am currently in the lengthy process of creating a bootable USB drive to make a Coffee Lake i7 8700k Hackintosh build. I'm following this guide with the recommended motherboard. I'll try to update here with my success/ failure.

  • Thank you. Trying to turn my msi into a triple boot today, and I wanted the latest and greatest of each OS because I'm OCD like that, haha. I'll post back if it all works out.
    – omikes
    May 19, 2018 at 20:48
  • 3
    Rather than copying the contents of macOS Install Data just copy the entire folder and rename it to SharedSupport. This way you will copy the invisible files even if you haven't configured Finder to make them visible. Jan 24, 2019 at 0:13
  • After step 4, my macOS rebooted without prompting so I wasn’t able to stop it. Weird. Apr 18, 2019 at 20:36
  • 1
    @FranklinYu Just select "Quit" from installer application menu before small 30-second timer will expire.
    – eraxillan
    May 27, 2019 at 13:05
  • 1
    This is a bad answer because the /macOS Install Data will give you a InstallESDDmg.pkg file not a InstallESD.dmg file.
    – Shayan
    Oct 23, 2019 at 21:57

First, it would appear that you have not downloaded a correct app from the App Store. The correct "Install macOS High Sierra.app" should be 5.18 GB.

Second, you are using the wrong syntax for the createinstallmedia command in the High Sierra installer. You now don't need the --applicationpath parameter. Check out this Apple support page.

  • I haven't downloaded macOS High Sierra, yet, but looking at it in the App Store it states, "Size: 4.80 GB". Do you have an actual size on it? Sep 26, 2017 at 4:20
  • About the --applicationpath parameter I tried whithout it same result. I had to install High Sierra and then re download the install app. I don't know why it wasnt working, I even tried on 3 different macbooks nd same thing.
    – Gerardo
    Sep 26, 2017 at 4:21
  • There is no need for the --applicationpath parameter when using createinstallmedia from High Sierra. See: support.apple.com/en-us/HT201372
    – lpacheco
    Sep 27, 2017 at 4:57

So, the guys from DiskMakerX gave me an answer to solve this problem.

Many people (including yours truly) were sometimes getting an installer application “stub” when downloading the Install macOS High Sierra application from the App Store. This “stub” application did not include the Contents/SharedSupport folder or its (very important) contents. The needed resources were instead downloaded “on-the-fly” when you ran the Install macOS High Sierra application.

This “stub” application is not useful as something to import into your Munki repo, or to use with AutoDMG or autonbi, or similar things. For these you really want the full installer, that is, one that contains all the needed installation resources in Contents/SharedSupport.

Many theories and ideas were put forth as to what caused one to get the stub vs the full installer. While I’m still not 100% sure about this, I think we’ve narrowed in on the cause.

It appears that when the App Store is downloading the installer app, it also uses softwareupdate to get the resources that normally reside in Contents/SharedSupport. If com.apple.SoftwareUpdate has been configured to use a CatalogURL that points to a softwareupdate catalog that does not contain product URLs for the needed Install macOS High Sierra resources, you get the “stub” application instead.

If, however, softwareupdate is using either Apple’s default CatalogURL, or is pointed to an internal CatalogURL that contains the needed products, you get the full installer.

Currently, the needed resources are Product 091-34298, “Install macOS High Sierra”, but this will almost certainly change over time.

TL;DR: to get a full High Sierra installer from the App Store, make sure softwareupdate is pointed at Apple’s softwareupdate servers or an internal server in which you have synced and made available the “Install macOS High Sierra” product.

Here's the info if someone else is having the same issue.

Some stuff about install macOS High Sierra.app

And I found another solution... Install the latest OS updates from the App Store and after that you should get the full installer.

  • 1
    The last sentence is the correct answer: if you have a fully updated Sierra (or, presumably, later), you get the full installer.
    – Ivan X
    Sep 28, 2017 at 3:13
  • "to get a full High Sierra installer from the App Store, make sure softwareupdate is pointed at Apple’s softwareupdate servers or an internal server in which you have synced" - But how do you do that???
    – CoderDave
    Oct 5, 2017 at 20:29
  • This makes me hate apple like five times more than I already do lately, but thanks
    – Dmitri DB
    Oct 20, 2017 at 2:47
  • What's amazing is I wait like over an hour and a half for this to fully complete, and the install file is still like 15MB. Looks like I'm stuck!
    – Dmitri DB
    Oct 20, 2017 at 4:35
  • @CoderDave To check if you are pointed at a custom software update server (SUS) run: defaults read /Library/Preferences/com.apple.SoftwareUpdate.plist CatalogURL If the Terminal returns a value, that is your update server. If it returns something like: The domain/default pair of (/Library/Preferences/com.apple.SoftwareUpdate.plist, CatalogURL) does not exist you are already pointed to Apple's servers. To delete a custom value run this command: sudo defaults delete /Library/Preferences/com.apple.SoftwareUpdate.plist CatalogURL Jul 6, 2018 at 20:25

Here is what worked for me on Yosemite.

1) Close the Mac App store app and then open up the terminal.

2) Reset software update catalog

$ sudo softwareupdate --clear-catalog
softwareupdate: Changed catalog to Apple production
  • --clear-catalog seems to reset the configuration and ensure that software update is pointing at the right place. For some people, they report that just running this, rebooting and then trying through the Mac App Store again is enough to get the full download. That didn't work for me however.

3) List available updates to see if High Sierra shows up.

$ sudo softwareupdate --list
Software Update Tool
Copyright 2002-2012 Apple Inc.

Finding available software
Software Update found the following new or updated software:
   * Install macOS High Sierra-
    macOS High Sierra ( ), 5106655K [recommended]
  • If it doesn't show up...then this probably won't work for you.

4) Download the update

$ sudo softwareupdate -v -d 'Install macOS High Sierra- '
Software Update Tool
Copyright 2002-2012 Apple Inc.

Finding available software

Downloading macOS High Sierra
   Progress: 1%
   Progress: 2%
   Progress: 99%
   Progress: 100%
Downloaded macOS High Sierra
  • The -v flag gives me download progress.
  • Because the update has spaces in the name it must be quoted.
  • There is a space at the end of the name...doesn't work without it...awesome right? Took me a few minutes to figure that out. If you are getting Install macOS High Sierra-: No such update even though it shows up in the list of downloads...that is probably your issue.

5) Install the Downloaded Update (installs the installer, not Sierra)

Downloaded softwareupdate files are kept in /Library/Updates.

$ ls -1 /Library/Updates/

In this case it happens that the high sierra download is 091-76348 which you can verify by taking a look in the dist file.

$ grep 'Sierra' /Library/Updates/091-76348/091-76348.English.dist

Once confirmed you can "install" the installer like so:

$ sudo installer -pkg /Library/Updates/091-76348/091-76348.English.dist -target /

Note that if you are installing a different language version you will probably need to change English to something else. Just ls /Library/Updates/091-76348/*.dist to see what "dist" files you have. (@chelder's comment)

After the installer completes, you should see that the full High Sierra installer is now in your /Applications folder.

$ ls -d -1 /Applications/Install*
/Applications/Install macOS High Sierra.app

...and it is the full 5GB

$ du -h -d0 /Applications/Install\ macOS\ High\ Sierra.app
4.9G    /Applications/Install macOS High Sierra.app


There are a few blog posts discussing this but there doesn't seem to be a conclusion why some people only get the "stub" (the 14-22MB file) and others get the full 5GB download. To make a USB boot disk you need the full file. The "stub" will work for normal (non clean installs) and downloads the necessary files on the fly.

  • This solution also worked for me (also in Yosemite)! Notice I needed to do a little modification: instead of typing English, I had to change it to Spanish. So instead of "/Library/Updates/091-76348/091-76348.English.dist", I typed "/Library/Updates/091-76348/091-76348.Spanish.dist"
    – chelder
    Aug 8, 2018 at 10:24
  • Typing: bash-3.2# softwareupdate -v -d 'Install macOS High Sierra- ' got a "No updates are avialable" Aug 10, 2021 at 19:53
  • @SherwoodBotsford - does High Sierra show as an available update under the Mac App store/updates section? This answer is about getting the full-sized installer for an available macos update (seen in the updates GUI). Apple changes the availability of various updates as they release new OS/versions, so it may be indeed that HighSierra is not available as an update for your current hardware/OS version.
    – mattpr
    Aug 12, 2021 at 10:38
  • It does not. Nor does it it show up from the command line tool. I think this is an end of support issue. Aug 12, 2021 at 21:58

It is indeed SharedSupport folder missing that causes this. In order to fix it, you should launch the small 'stub' installer, it will download all needed files to your home (/Users/username). You will need to cancel the installation after downloading ends of course.

Then if you just move those files to 'stub' installer folder, like this for example:

sudo mv /Users/username/macOS\ Install\ Data Applications/Install\ macOS\ High\ Sierra.app/Contents/SharedSupport

and run createinstallmedia again, it will do what we want it to do.


It can be quite challenging to get a full version of the High Sierra installer if you don't want to use third party scripts or untrusted sources. The official way is a download from MAS via the link on this page from Apple's KB but likely this only downloads the stub installer w/o the actual payload.

If you happen to have a Catalina machine around, there is now a second officially supported way to get it:

softwareupdate --fetch-full-installer --full-installer-version 10.13.6

With that the full installer is downloaded and placed in /Applications so you can directly use createinstallmedia with it.

  • I get a "no such update" Aug 12, 2021 at 21:56
  • @SherwoodBotsford: this can happen if a) the requested version is no longer offered for download (usually only the latest updates are available) and b) if the requested OS isn't supported on the machine running that command. See apple.stackexchange.com/a/389624/85149 From BigSur onwards you also have softwareupdate --list-full-installers which does what it says and is very handy.
    – tbussmann
    Nov 25, 2021 at 11:37

I am also facing this issue of the installer being 16 MB. I tried several times but out of luck. Then I downloaded the DMG files directly fro Apple's site and used it to update my system



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .