2

In macOS 10.12.6 , I am trying to forward the clock using the date command.

E.g.: today's date is 25-09-2017 and I am setting it to 27-09-2017. But using ntp I am unable to revert my system time back to 25-09-2017.

I have "time.asia.apple.com" set in /etc/ntp.conf.

When I try to issue the command

sudo killall -9 ntpd; sudo ntpdate "time.asia.apple.com"

I am getting the following output:

27 Sep 20:25:36 ntpdate[5085]: no server suitable for synchronization found

I am not sure why my system time is not moving back to 25th of Sep.

I even tried it with "time1.google.com" . The clock is still not returning back to today's date.

1

"no server suitable for synchronization found" indicates that the time server time.asia.apple.com can't be found or in-bound ntp traffic is not allowed at some perimeter.

Your host either has no proper Internet connection or DNS resolution is wonky.

However, you can try to check your Internet connection (e.g. ping 8.8.8.8), repair the Internet if necessary (e.g. repair Internet local|global all) and repeat your ntpdate command or use one of the various IP addresses of time.asia.apple.com (17.253.52.125, 17.253.54.253, 17.253.54.125) directly:

sudo ntpdate 17.253.54.125

If the last command works DNS resolution is broken.


repair Internet local|global all shouldn't be taken literally.

  • i checked the internet connection. i am able to surf internet and ping 8.8.8.8 is working as well. – srinath Sep 26 '17 at 16:28
  • i am able to ping both via IP and time.apple.com or other ntp servers like time1.google.com. Still when i issue ntp command, i get the synchronization error. – srinath Sep 26 '17 at 16:29
  • Checked firewall as well. its not blocking the ports. Any other thing that needs to be checked ? – srinath Sep 26 '17 at 16:29
  • yes.. we have a ntp server running. and we have synced with the ntp server before as well. but now , its not working – srinath Sep 26 '17 at 17:17
  • is there any other way we can restore back the system time apart from ntp – srinath Sep 26 '17 at 17:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .