21

I created an encrypted disk on a USB drive the other day, and added a password hint. I don't remember what the password is. (I have a scheme for mapping hints to passwords, so when there's a hint available I just pick something random and write out the appropriate hint.)

When reconnecting the disk today, OS X popped up the password prompt - but no hint displayed.

When I go into Disk Utility and try to mount the volume, same thing. Not even a button to show the hint!

So now I've got no idea what the password is. How do I find out the hint?

OS X 10.12.6 (16G29)


Here's the process I went through. (I went through it again using a spare SD card and took screen grabs at each point.)

  1. From Disk Utility, select disk in question and go to the Erase option. Select Mac OS Extended (Journaled, Encrypted)

enter image description here

  1. The password box appears. Enter password and add a hint.

enter image description here

(I usually pick a more cryptic hint than that)

  1. Click Choose, then click Erase, and it will do its thing. Click Done once it's done, and quit Disk Utility.

enter image description here

  1. Eject the newly-mounted encrypted disk image from Finder, then unplug USB hard drive.

  2. Reinsert USB hard drive and wait for password dialog to appear.

enter image description here

But where's the hint?!

  • 2
    Yes - and entering wrong passwords don't seem to show the hint that was saved. I'm sure there used to be a Show Hint button, that you could click to get the hint. – Tom Seddon Sep 24 '17 at 15:15
  • 3
    Sounds like you’ve either fallen into a trap or stumbled over a bug. Neither would be comfortable. – bmike Sep 24 '17 at 16:21
  • 4
    I note that diskutil has no obvious options for password hint when you're encrypting a disk. So I wonder what Disk Utility actually even does with the text you enter. Will look through the programming docs later and see if I can find any more clues... – Tom Seddon Sep 24 '17 at 16:54
  • 5
    Apparently on 10.13.0 the hint is a little too specific and clear. medium.com/@matheusmariano/… – bmike Oct 5 '17 at 8:57
  • 3
    On the login screen the hint doesn't appear until you enter a password incorrectly. Have you tried intentionally inputting the wrong password a couple of times? – Allan Nov 7 '17 at 19:32
1

Have you tried entering an incorrect password? If I enter a wrong password three times, I get the hint displayed.

  • 1
    I have tried this, but the comment I added at the time maybe doesn't make this super-clear. Anyway: yes I have, and I don't get a hint. (I tried entering the wrong password a lot more than three times.) – Tom Seddon Mar 23 '18 at 12:52
  • 1
    Sorry, I did replicate this, but I did it with an encrypted DMG, not with an external drive. Hmm. This seems odd and might be worth contacting Apple. – lbutlr Mar 23 '18 at 21:54
  • Not long after posting this question, I used the Contact Apple thingy to file a report, along with a link to this question. I expected nothing from this, and Apple have met my expectations. – Tom Seddon Mar 25 '18 at 22:51
0

If you upgrade to MacOS High Sierra 10.13.6 (17G65 at least), you can find the hint back when you use APFS file system with (Case-Sensitive, Encrypted) options

  • Can you confirm that this works for you with a drive encrypted with Disk Utility, rather than a disk image? I have the same problem and am at a loss about what to do! – mmorin Nov 12 '18 at 16:36
  • Please provide step by step instructions, e.g., with images - this answer is, as provided, not at all clear to me. – Tom Seddon Jun 2 at 18:20
-2

Do you have any older Macs? You could try mounting it on an older Mac OS. As is often the case with Apple, features that have disappeared still work on older OSes.

  • I have the same problem and went to the Apple Store, where I connected the drive to a Mac running a Virtual Machine of 10.10, the earliest they had. The hint did not show. – mmorin Nov 12 '18 at 10:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .