Before iOS 11, the default quotation marks were the ASCII ' and ", but now they are changed to ‘’ and “” (curly quotation marks). I have to long press the quotation mark key on the soft keyboard to type the normal ones and have no way to type them on a Smart Cover.

I’m a programmer and I have to use ' and ", is there any way to change them back?

I suspect this problem is linked to my language and region settings, I’m in China and my iPad language is English by the way.

up vote 7 down vote accepted

Go to system prefaces, keyboard. In the keyboard window click on the text tab. In this window, on the right, is an option to use smart quotes. Uncheck the box.

  • Only upgraded to iOS 11 from 9 today and spent the whole day reverting all the stupid stuff they've done. Cheers for tip! – Matt Fletcher Jan 1 at 20:49
  • 1
    This answer is for macos and is not correct for ios – Tom Gewecke Apr 11 at 14:51

It's in Settings | General | Keyboard | Smart Punctuation.

  • These are the correct menu item labels for iOS on iPhone. The other answer might be correct for iPad (I don't have one handy) but this one was right for my device. – Seyren Jan 8 at 7:18
  • @Seyren the other answer is wrong for any ios device – Tom Gewecke Apr 11 at 14:52
  • 1
    This is the correct answer for iOS 11. The former answer refers to recent versions of macOS (10.9 onward). – Jeevan Takhar Apr 12 at 21:43

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.