1

I've got a point of sale terminal/pinpad connecting to the internet through the ethernet port on my Mac mini, which has internet sharing turned on. It works... but it takes almost 5 minutes for my POS software to talk to the terminal. It used to work perfectly and then a few days ago it just started taking it's sweet A$$ time. Nothing changed. No bloody idea. I digress.

I feel like if the pinpad was on the same network than it would fix the issue.

Tried creating a bridge via terminal. Pinpad didn't get an address, but it's using DHCP so maybe that's the issue.

Tried creating a bridge through system preferences but that killed the internet to the Mac and still didn't give access to the pinpad.

The Ethernet connection in Network Preferences is yellow and says "self-assigned IP"

Please help! Thanks a bunch.

6
  • Have you tried rebooting your Internet Gateway (modem)? The self assigned address means it didn't get an IP address from your ISP/Gateway
    – Allan
    Commented Sep 24, 2017 at 1:04
  • yeah I have. doesn't make a difference.
    – SargeLunch
    Commented Sep 24, 2017 at 17:57
  • That makes a huge difference. Until that self assigned IP is resolved, you can't connect to the Internet through it. How are you connecting now?
    – Allan
    Commented Sep 24, 2017 at 21:57
  • The pinpad uses DHCP
    – SargeLunch
    Commented Sep 26, 2017 at 17:09
  • I don't know what that has to do with my comments.
    – Allan
    Commented Sep 27, 2017 at 21:37

1 Answer 1

1

In the end, after trying a dozen different things, this command in terminal fixed my problem. networksetup -setv6off Wi-Fi

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .