2

I've had this issue for about a year now, but never cared about it. Now I'm very motivated to fix it. :)

So I wanted to enable FileVault for my system but somehow it got stuck. I'm running El Capitan 10.11.6. It's a MacBook Pro (Retina, 13-inch, Early 2013).

$ diskutil cs list
CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group EA8CE898-9E59-4AE3-A61A-0483E0348B70
    =========================================================
    Name:         Macintosh HD
    Status:       Online
    Size:         249490432000 B (249.5 GB)
    Free Space:   1152106496 B (1.2 GB)
    |
    +-< Physical Volume 0EE26D70-A5FA-40F6-BF42-20E30E4D47C9
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     249490432000 B (249.5 GB)
    |
    +-> Logical Volume Family 9756B87D-76C6-4923-AFD6-B183C6BFABB2
        ----------------------------------------------------------
        Encryption Type:         AES-XTS
        Encryption Status:       Unlocked
        Conversion Status:       Pending
        High Level Queries:      Not Fully Secure
        |                        Passphrase Required
        |                        Accepts New Users
        |                        Has Visible Users
        |                        Has Volume Key
        |
        +-> Logical Volume A84FF2DD-B511-47F1-BA9A-3E7BC522B42C
            ---------------------------------------------------
            Disk:                  disk1
            Status:                Online
            Size (Total):          247763697664 B (247.8 GB)
            Conversion Progress:   Paused
            Revertible:            No
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS
            LVG Type:              Sparse

I've spent a day looking up fixes and trying out solutions (dozens of times). Here's what I've tried so far:

  1. Boot into recovery mode, unlock and repair disk. I get green checkmarks but no luck in unpausing encryption.
  2. Boot into recovery mode, run corestoraged, no luck.
  3. Both of the above in normal boot. No luck.
  4. Tried to move the corestorage daemon but could not, the FS is read-only.
  5. fdesetup disable did nothing as well. It succeeded but no change to filevault.
  6. fsck_cs -y disk_identifier_goes_here succeeded but didn't unpause the Filevault conversion.
  7. Tried to upgrade to Sierra but the installer complained about Filevault conversion in progress (https://i.imgur.com/k9ABpmI.png)
  8. (After giving up hope, backing up to Time Machine) Boot into recovery mode, try to reinstall macOS there. Same error as 6.

So at this point. I have run out of ideas, and can't even start from scratch. How do I un-screwup my system at this point? I am okay with wiping my hard drive and restoring from a TM backup.

1

So I figured I've tried all I can so let's just try erasing the disk. That worked.

Here's what I did:

  1. Time Machine backup to a disk.
  2. Time Machine backup to another disk because I'm not risking it.
  3. Recovery mode.
  4. Disk Utility -> Select Macintosh HD -> Erase.
  5. In recovery mode, Recover from a TM backup.

Now the system's good!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .