11

How to permanently turn off check spelling while typing in macOS - for each and every app. Whenever I turn off this option in anyone of my default or third party mac apps within a few seconds these option turns itself on automatically, so is there any option to turn this off permanently across each and every app?

I have already tried each and every solutions mentioned in this question Can't disable 'Check spelling while typing' in 'Notes' in OSX El Capitan 10.11.6

But still it automatically gets turned on!

4
  • Is it automatically on for new documents, or only existing ones? I'm pretty sure the pref is saved in the document itself.
    – Tetsujin
    Sep 23, 2017 at 17:21
  • @Tetsujin.On for everything - old and new!
    – Sayan
    Sep 23, 2017 at 17:33
  • hmm... then idk, sorry - There's a long, but ultimately successful QA on how to disable it via Applescript/key command here - apple.stackexchange.com/questions/208746/… in case you find no better alternative.
    – Tetsujin
    Sep 23, 2017 at 17:49
  • let's see if anyone saves me from this issue!
    – Sayan
    Sep 23, 2017 at 18:18

3 Answers 3

8

Go to system preferences, keyboard. Click on text tab and there is an option on that window to correct spelling automatically. Uncheck that box.

5
  • 3
    I have tried that and as I have said in my question - I have tried everything but still macOS doesn't stops this annoying spell checker
    – Sayan
    Sep 23, 2017 at 16:38
  • 1
    have you tried turning off spell checker from the edit menu of most apps? it sounds like you have.
    – Natsfan
    Sep 23, 2017 at 16:44
  • Yeah tried that too!
    – Sayan
    Sep 23, 2017 at 16:55
  • There is still some red lines beneath the words Mac deems grammatically incorrect...
    – mhyousefi
    May 24, 2020 at 8:14
  • 4
    The OP asks for a solution to turn off spell checking, not correction. They are different things, and this answer doesn't address the actual question. Mar 26, 2022 at 21:55
7

to permanently and Globally [system wide] turn it OFF you have to do it via terminal, using defaults command

By "system wide" I mean: Will be turned-off for all applications, for the current user, (which will execute the command below). It will NOT affect (will not turn it off) for other users which may exist on the same MacOS machine.

Lets do it:

Open Termina.app, and copy/paste these 2 commands:

First command:

defaults write NSGlobalDomain NSAutomaticSpellingCorrectionEnabled -bool false

Second command:

defaults write NSGlobalDomain NSAutomaticTextCompletionEnabled -bool false

After it, logoff and logon again, or reboot.

After logging in, those options will be disabled by default for every MacOS app, and if you wish, you can enable it individually for each app where it is necessary. (basically the behaviour will be the opposite of the behaviour you described on your question.)

.

How to Revert it back to Original Behaviour:

If you need/want to revert the behaviour back to the original, change the last command line word "false" to "true", execute both commands and log-off/on again.*

Example to revert back to original behaviour:

defaults write NSGlobalDomain NSAutomaticSpellingCorrectionEnabled -bool true 

defaults write NSGlobalDomain NSAutomaticTextCompletionEnabled -bool true

------ ** The Answer for OP finishes here - But I will expand it with more related information below** -----


PS: Extending this answer a little, which may be helpful for others. There are 6 variations which can be explored/configured, to fine-configure those grammar settings:

They are:

  • NSAutomaticCapitalizationEnabled
  • NSAutomaticDashSubstitutionEnabled
  • NSAutomaticPeriodSubstitutionEnabled
  • NSAutomaticQuoteSubstitutionEnabled
  • NSAutomaticSpellingCorrectionEnabled
  • NSAutomaticTextCompletionEnabled

Just use the same syntax as the answer, substituting the command for anyone of those 6 commands, and using True or False as the answer above instructed to activate/deactivate each one.

3
  • 1
    I can't permanently turn off the shitty red underline from Textedit. I've tried everything but nothing helps. It's the last annoyance left. Any idea? Dec 4, 2021 at 11:48
  • 2
    The OP asks for a solution to "turn off check spelling while typing". None of these suggestions accomplishes that. They disable spelling correction etc., but not checking (the red underlines). Mar 26, 2022 at 21:51
  • Setting NSAutomaticPeriodSubstitutionEnabled to false doesn't work in Sonoma.
    – Rain
    Apr 3 at 4:13
2

If the accepted answer doesn't work, try this:

  1. Right click anywhere in the document
  2. Find "Spelling and Grammar"
  3. Uncheck "Check Spelling While Typing", and optionally "Correct Spelling Automatically".
1
  • 2
    The OP states that they have tried this already: "Whenever I turn off this option ... within a few seconds these option turns itself on automatically". The request is for a solution to turn it off permanently, which this answer doesn't provide. Mar 26, 2022 at 21:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .