2

In iOS 11 when we disable the Wi-Fi in the control center it doesn't actually disable the radio. According to Apple, the device is disconnected from Wi-Fi and auto-join is disabled until

  • You turn on Wi-Fi in Control Center.
  • You connect to a Wi-Fi network in Settings > Wi-Fi.
  • You walk or drive to a new location.
  • It's 5 AM local time.
  • You restart your device.

When I disable Wi-Fi (or BT) I really want it off. Is it possible via some setting or application to get the old behavior back?

marked as duplicate by kenorb, Tetsujin, nohillside Dec 13 '17 at 18:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Workaround: turn on Airplane Mode and re-enable Cellular/Bluetooth. – haykam Sep 23 '17 at 16:48
  • @kenorb I think the question you ultimately link to came after this question (23-Sept vs 28-Sept). So wouldn't that question be a duplicate of this question? – fsb Dec 13 '17 at 17:57
  • 1
    The canonical answer isn't necessarily the first, it's the one with the most interest & fullest answer, also hopefully an accepted one. (That it's my answer being debated has no relevance, purely coincidental... I can survive the rep hit if the canonical answer changes ;) Linking dupes [in any order] leads more people to a question that has a series of potential answers for their particular issue & lets google find more potential routes to that answer. – Tetsujin Dec 13 '17 at 18:12
  • I think it's actually duplicate of: Wifi Automatically Turning ON after iOS 11 Update which has definitely more votes and views. – kenorb Dec 13 '17 at 18:17
2

The Apple site you linked to indicates how to completely turn off Wi-Fi and Bluetooth:

If you want to completely disable Wi-Fi and Bluetooth for all networks and devices, follow these steps:

  • To turn off Wi-Fi, go to Settings > Wi-Fi and turn off Wi-Fi.
  • To turn off Bluetooth, go to Settings > Bluetooth and turn off Bluetooth.

For the best experience on your iOS device, try to keep Wi-Fi and Bluetooth turned on.

  • I am aware you can do it via settings > Wi-Fi. I asked about getting the old behavior back, i.e. toggle the button in the control center to switch the radio off. – Daniel Sep 23 '17 at 14:14
  • No, as you've already found, Apple changed that behavior and there's no way, outside of jailbreaking, that will allow you to change that. – fsb Sep 23 '17 at 23:14

Not the answer you're looking for? Browse other questions tagged .