I had an app called "Gitbox" on my Mac for 4 years with no problems. App suddenly does not display it's main window when running. The little dot is under the app in dock. I cannot delete the app when the dot is there, cause OS says it's running. I can verify the app is running, because the "Activity" window shows that it's fetching something.

I tried reinstalling, and looking at other "Windows" or desktops, but nothing. Did I use some launch option or hotkey to launch the app in a wrong mode?


  • Rebooting Mac
  • Reinstalling App from the app store
  • Dragging and restoring to Trash

enter image description here

enter image description here

  • 2
    and the name of the App is...... – Allan Sep 23 '17 at 12:31
  • The name is Gitbox, it's a source control tool – Alex Stone Sep 23 '17 at 13:06
  • hmm last update 5.5 years ago. Already tried to (re)move the prefs file? – klanomath Sep 23 '17 at 13:52
  • 1
    In Script Editor, with Gitbox running, what's the output of this command: tell application "System Events" to get properties of window 1 of application process "Gitbox" – user3439894 Sep 23 '17 at 14:22
  • System Events got an error: Can’t get window 1 of application process "Gitbox". Invalid index. – Alex Stone Sep 28 '17 at 2:17

Deleting the preferences here has resolved the problem. Not sure why they did not show up in finder, I think it shows hidden files for me. So I had to use an external tool which actually found hte preference file:

enter image description here

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .