0

I've got no sound from Flash in Firefox running my MacBook pro through HDMI cable and I've found a similar question from '15 on the, cached, Adobe Forums

When viewing video with flash player in firefox the sound is played through HDMI altough my USB headset is set as the default sound device. All other sound is played trough the default sound device EXCEPT flash player sound.

Restarting firefox doesn't help.

Reinstalling the flash player plugin doesn't help.

To which the answer says:

Yeah, this is a lingering Firefox problem, and it's related to limitations in how we had to retrofit sandboxing to the NPAPI. The best workaround is probably to just use Chrome. I forget the exact reason why (this has been a problem for years) but the low-integrity Flash Player process doesn't have permission to call into the Windows Sound APIs necessary to set the correct output target, and I don't believe that we can broker it safely for some reason.

Mozilla has recently engaged in a collaborative effort with us to improve the overall experience with Flash in Firefox by addressing some of these long-standing architectural deficiencies. Our hope is that we'll be able to provide both a secure and efficient Flash implementation all around, but that effort is going to take at least several months before it reaches customers (and we're doing incremental stuff in the meantime).

Sorry I don't have better news on that front.

The Q&A is a good two years old, I'm hoping there has been some improvements by now.

Any fixes?

1

The solution I've found is to use the HTML5 Video Player.

Flash can be blocked or turned off in "manage plug-in use" - the grey looking lego-type piece with a blue dot at its top right - next to the url:

enter image description here

which, if flash is on, will bring up something like this:

enter image description here

at which point you can block it.

Upon restarting Firefox it will stop trying to use Flash automatically and default to the HTML5 Video Player. The HTML5 Video Player in Firefox has no problem passing audio through HDMI.

Not all flash based videos - or services - can also use the HTML5 Video Player, but for those that can this is a great solution.

0

In my experience, changing the available audio outputs on macOS does not always propagate properly to all running applications and processes. First, make sure you have selected the HDMI audio output, for example by Option-clicking on the speaker symbol in the status bar. If it still doesn’t work, try restarting Firefox after you have connected the HDMI cable and selected the HDMI audio output.

  • Tried all of those. It’s only flash on Firefox that isn’t going through the hdmi cable. – user3306356 Sep 21 '17 at 19:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .