0

When I copy a block of text more than about twenty lines long to the clipboard, pasting only pastes a hyphen character.

Why is the clipboard buffer so small and how can I increase it?

  • I wonder if it could be either a program error or a limit of the application you're copying from. I did a test and copy&pasted 101641 rows of text with no issues. Pics: App I pasted fromClipboard history app. – Joonas Sep 21 '17 at 12:20
  • What app did you copied the text from and what OS are we talking about (macOS/iOS)? – oa- Sep 21 '17 at 12:56
  • I suspect it's an app issue rather than the OS. I have this problem copying text from a Chrome browser Jupyter notebook cell into Sublime Text 3 (jupyter.org & sublimetext.com). Tried using Paste and Match Style but no difference. – Ollie Glass Sep 21 '17 at 16:18
1

You should not hit the clipboard buffer limit in normal use, it is far bigger than a “block of text”. Depending on where you copy from, the source application might be transforming the buffer before storing it. Especially some websites have scripts for these kinds of interceptions in an attempt to prevent large-scale copying of copyrighted information – in these cases you can often work around using the Edit > Copy menu item instead of the Cmd-C shortcut, for example. Other applications might change the clipboard format after reaching a certain size, and might then have a bug when generating e.g. a Rich Text buffer versus a Plain Text buffer. Another thing you could try is pasting with the Paste and Match Style option, by choosing it from the Edit menu or pressing Ctrl-Shift-Cmd-V.

  • This happens to me occasionally. if I click on the hyphen, the text appears. – jmh Sep 21 '17 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .