3

I have a plain disk image, created from using dd. When I try to mount it in Sierra (10.12.6), DiskImageMounter.app tells me:

legacy image should be converted

enter image description here

How do I perform such a conversion?

I tried hdiutil but had no success:

$ hdiutil convert -format UDCO -o output.img input.dimg 
hdiutil: convert failed - image not recognized

The trouble may come from the fact that this image contains the contents of the APFS container partition, so DU may not recognize it as any known format. Still, it should allow me to convert it into a plain disk image so that I can at least attach it, even if it won't mount.

Alternatively, how can I attempt to attach a plain disk image with some other command (not hdiutil) so that I could then use Disk Utility to make a new image from it? I mean the way I can use the loopback interface on Linux, for instance.

Note: The original Disk Utility (pre-10.11) was apparently still able to convert such an image, but the new one isn't.

  • This is why I love virtualization software. I use VMWare Fusion. I have operational Virtual machines from 10.7 to 10.13. I backup the fresh installs of these VMs so that if I forget to take snapshots I can always start brand new. The latest edition of VMWare has always been able to run an old virtual machine for me. Yes, there are sometimes bugs to work out on another layer in an emulation environment, of course. However, ATM, the only outstanding issue is 10.10 not working with USB 3.0 after last security patch. I just dropped my legacy .dmg file into my 10.9 machine, convert or grab files. – NOTjust -- user4304 Sep 1 '18 at 6:02
4

This worked on High Sierra. This is from an ancient DC42 image format from a 512Ke system disk.

Todds-MBP-7:$ hdiutil convert Utilities1.image -format UDRO -o Converted
Preparing imaging engine…
Reading whole disk (Apple_HFS : 0)
.........................................................
(CRC32 $7335686D: whole disk (Apple_HFS : 0))
Adding resources
Elapsed Time:   2.822ms
File size: 729282 bytes, Checksum: CRC32 $E4490B5F
Sectors processed: 1600, 1417 copied
Speed: 245.2Mbytes/sec
Savings: 11.0%
created: /Users/WFN32919/Downloads/converted.dmg
  • 1
    Yes, that's the normal way how it's supposed to work. It probably worked for you because you had a more regular disk image format (unless High Sierra fixed a bug that I ran into with Sierra). But it does not seem to solve my specific question. Still, it answers the general title of my question (I should have been more specific there), so I'll upvote it in case others run into this question as well. – Thomas Tempelmann Feb 13 '18 at 6:34
  • @ThomasTempelmann thanks... saved me some time, just used virtualization instead. – NOTjust -- user4304 Sep 1 '18 at 6:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .