7

Upgraded to iOS 11 and noticed that my share-sheet no longer includes the option to share in Messages. Has anyone experienced this and know how to get the functionality back?

I’ve confirmed it hasn’t been disabled in the “more” options

This seems to be happening in most 3rd party applications and from the home screen when using “Share App” feature via 3-D touch

no share sheet not available under more options

5
  • Just making sure–are you signed in to iCloud?
    – SilverWolf
    Sep 26, 2017 at 21:03
  • I am, but don’t think that should matter. Messages still handles SMS text messages which supports iTunes URLs and photos
    – slidmac07
    Sep 26, 2017 at 21:04
  • Hm, yeah. I don't know, then. Does it still work in, say, the Photos app but just not in third-party apps, or does it not work in any app?
    – SilverWolf
    Sep 26, 2017 at 21:06
  • Doesn’t work in any app
    – slidmac07
    Sep 26, 2017 at 21:09
  • OK, weird. Does rebooting help? (Just rebooting fixes all sorts of wacky problems!)
    – SilverWolf
    Sep 26, 2017 at 21:10

4 Answers 4

0

I’d try installing the iOS 11.01 update via Settings > General > Software Update.

For more information, refer to: iOS 11.0.1: What’s New Or Changed?

1
  • Updated to 11.0.1 and still not working
    – slidmac07
    Sep 27, 2017 at 13:42
0

Do you have MobileIron installed? I do and experienced the same issue. I read that was causing it, so I uninstalled and Messages came back. Then I reinstalled MobileIron and it went away again. I downgraded to iOS 10.3 as Apple Support couldn't help easily.

I haven't tried since iOS 11.0.2 came out.

0

I had a mobile device management certificate installed and it was causing this. Removing it solved the issue. Found the answer via https://ios.gadgethacks.com/how-to/get-back-missing-message-icon-ios-11s-share-sheet-0180193/

0

This bug is now resolved in iOS 11.1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .