5

So I just finished my 4,1–5,1 build. I installed a pair of X5675's along with two sticks of Samsung 16GB DDR3,4RX4 PC3-10600R 1333MHz 240-pin ECC REG Server Ram, for 32Gb. Trouble is, it's showing up as 1066 instead of 1333. Now, the machine is running fine, but I'm curious as to why my memory isn't showing full speed–I triple checked the specs on that RAM before I bought it and thought it should work, and it does, but not at 1333. Tried zapping the NVRAM, to no avail. Anyone have any ideas?

  • I had the same problem. Try zapping P-Ram. OK – Okleydokley Feb 13 '19 at 1:30
  • The OP literally said, in the title of the question that the NVRAM reset didn’t work. Also, PRAM is for PPC Macs and NVRAM for Intel Macs – Allan Feb 13 '19 at 1:36
2

I can't find out what actually decides it, however I just noticed this note on the Apple KB - Mac Pro (Mid 2012 and earlier): How to remove or install memory

Note: Although the memory speed of the UDIMMS is 1333 MHz, they will operate at 1066 MHz or 1333 MHz depending on the processor in the computer.

Typically, MacPro5,1 models with one of the Nehalem processors only support a memory speed of 1066 MHz, while those with one of the Westmere processors support a memory speed of 1333 MHz. In your case, the X5675 processors are one of the Westmere variety, so I can't explain the discrepancy in speed.

I have a pair of X5690 in mine & RAM runs at 1333MHz.

It's probably worth making sure you have the pair in the correct places, just in case...

enter image description here

BTW, the Pros run fastest in triple channel - so if you can afford one more RAM stick...

| improve this answer | |
  • OK! Great info! I'll try all that! Thank you! Yeah, I'm planning on getting more RAM for sure, amybe as high as 96, which will be 6–16Gb sticks–get the most out of that triple channel function! – VCMSound Sep 22 '17 at 2:54
  • Hi, I just updated the firmware of my 2009 (4,1) mac pro to 5,1. I tried to swap out the dual processors for 5690s. I have 32GB of 1066 DDR3 ram, but after I upgrade the processors, the memory does not seem to be recognized (steady flashing white power LED). Do I HAVE to use 1333 RAM if I upgrade the processors to 5690 or can I just use my old RAM? – morphatic Apr 1 '18 at 3:11
0

It is known that 4rx4 modules does not work properly on Mac Pro, and when they work they do at 1066Mhz. The recommended modules are 2Rx4, in fact, they are faster on terms of latency

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .