0

I am using VMWare Fusion 8.5.8 on MacOS 10.12.6 with a guest of MacOS 10.12.5.

Periodically drag and drop stops working. Usually I can reboot and it will start to work again. This time a reboot did not fix it.

I contacted VMWare and they declined support because they claim it does not work and it never worked. They sent me this link supposedly supporting that, but by my reading it does not support their claim: https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1032440

I am quite sure that I use drag and drop between the guest and host previously as it is part of my development workflow.

Further supporting my claim that it previously worked I previously submitted a ticket about it not working, but by the time the support person got back to me I had to reboot and no longer had a test case for them to work on. They then suspended the ticket.

If someone could run a quick video of drag and drop working on they similar setup I would appreciated getting a copy so I could send it to VMWare to get them to take my issue seriously.

What can I try to get drag and drop to work again?

[EDIT] I updated the guest machine to 10.12.6 and drag and drop started to work again. Problem solved except I want to get to the bottom of it to keep it from happening in the future.

I just got this email from VMware claiming that this feature does not work:

** Please do not change the subject line of this email if you wish to respond. **

Hello Michael,

Thank you for your response.

This feature is not supported. Kindly refer the knowledge base article which lists the limitations for VMware Fusion 8.5.8 and also for the latest Fusion 10.

The feature may have worked in the earlier builds or may work intermittently with the newer version. However, we have checked with the engineering team and they have confirmed that we do not support the drag and drop feature.

These were the inputs which were shared directly from the engineering team: For MacOS guest, Drag & Drop/Copy & Paste file is not supported, it only supports copy text between guest and host. Like copy a string in TextEdit from guest and paste it to host's TextEdit.

So, it's not a bug

We request you to submit a feature request.

  • The VMware KB you linked states "Running VMware Tools in Mac OS guests has these limitations:" of which one is "Drag-and-Drop / Copy-Paste" and I can attest that both do work in a macOS Host/macOS Guest scenario, albeit both do stop at times and require restarting the VM to regain the functionality of Drag-and-Drop / Copy-Paste. Note that both do not necessarily fail together. I also use VMware Shared Folders when D&D is not working if I can't reboot at that moment. There is no need for a video since VMware's KB shows it has "Drag-and-Drop / Copy-Paste" in a macOS Guest. – user3439894 Sep 20 '17 at 15:38
  • @user3439894, I read that link the same as you, but the CSR does not. It can be claimed to be ambiguous as it is listed under limitations. Taking her point of view there is not reason to list it under limitations unless it is describing a feature that does not work. – Michael Potter Sep 20 '17 at 15:44
  • Listed Limitations can be both what does and doesn't work! The fact that is states "Drag-and-Drop / Copy-Paste" without any additional parameter on that given line, I take it as one of the the few features out of all the features VMware Tools provides as ones that do work, and they do work! (Most of the time.) – user3439894 Sep 20 '17 at 15:54
  • 1
    In the VMware Fusion 6.0.2 and VMware Fusion 6.0.2 Professional Release Notes under "Resolved Issues", it states: "Improved drag-and-drop to OS X guests." – user3439894 Sep 20 '17 at 16:33
  • 1
    In the VMware Fusion 8.5 Release Notes under "Resolved Issues" it states: The drag & drop operations might not work consistently between the host and Mac OS virtual machines Attempts to drag and drop files between the host and a Mac OS virtual machine occasionally fail. This issue is resolved. – user3439894 Sep 20 '17 at 16:47
1

I found out today that it does work with VMware Fusion 10.1.2 and VMware Tools 10.2.5 on Mac OS X 10.11.6 El Capitan but it doesn't work for me on macOS 10.13.4.

Probably this has something to do with User Authorized Kernel Extension Loading (UAKEL). If your Mac is managed by an MDM, kernel extensions are managed by User Approved MDM Enrollment (UAMDM) a management profile.

As far as I understand how Drag and Drop works, it used some kind of filesystem driver. Maybe this used to use a (third party?) kernel extension which is no longer trusted?

Further Readings:

UAKEL: https://developer.apple.com/library/archive/technotes/tn2459/_index.html

UAMDM: https://derflounder.wordpress.com/2018/04/12/whitelisting-third-party-kernel-extensions-using-profiles/?_sm_byp=iVV4WQj4MknqbVsJ

  • Just to record it to find a pattern: drag and drop worked for me right this minute from host macOS 10.12.6 to guest 10.12.6. – Michael Potter Jun 15 '18 at 3:39
0

Drag and drop was supported as can be seen in this YouTube tutorial at 08:36 https://www.youtube.com/watch?v=kR28kVtZYJY

  • The OP never said Drag & Drop wasn't supported. He said it stopped working and this doesn't answer the question. – Allan May 14 '18 at 14:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .