Since updating to iOS 11, search is unable to find my apps. Is this a new feature of iOS 11; a bug; or something that will eventually resolve itself over time?

I have so many apps that the only practical way to find them is to search for them, and in the past this has worked perfectly. E.g. simply typing "stack" (in fact just "st") suggests several apps including the one I'm looking for, 'Stack Exchange' listed right at the top of the screen.

Now however I get a very different result:

A bunch of useless search results at the top, and a suggestion from the app store for an app I'd never want. No sign of the frequently used app sitting right on my device.

What's going on here. Is there anything (short of restoring iOS 10) that I can do do address this?

Judging from the behavior I'm seeing I wonder if Apple hasn't changed the meaning of the Siri setting for apps from meaning "search in the app" to "search for the app": the only apps I see at all are ones where this setting is enabled. Is that perhaps what's happened (or does having this on just get those apps indexed first)?

  • Maybe the index needs to be rebuilt? When I type 'st' the first of my apps returned is Stack Exchange. I don't think it's a bug but maybe (I'm guessing here) is that the index of apps, etc, needs to be rebuilt over time and use.
    – fsb
    Commented Sep 20, 2017 at 12:31
  • @fsb:On iOS 11? If so, long have you had it installed?
    – orome
    Commented Sep 20, 2017 at 12:32
  • I just installed 11 on my iPhone 6 about 20 hours ago. I didn't have a beta on my iPhone prior to this, either. I just experimented with typing the names of various other apps I have and each one came up within typing 2 letters of the name. I don't know what's wrong with your device nor do I have any suggestion of how to fix it, i'm just letting you know that my iPhone works as expected.
    – fsb
    Commented Sep 20, 2017 at 12:54
  • @fsb: Maybe I just have too many apps!
    – orome
    Commented Sep 20, 2017 at 13:00
  • 3
    @fsb: Hope so. It's pretty irritating to have my device advertising to me instead of doing its job. Yay Apple (yet again).
    – orome
    Commented Sep 20, 2017 at 13:02

6 Answers 6


If you are unable to search for apps you could once find, check your settings to see what apps you prevented Search from searching within.

Apple recently changed the behavior of the relevant setting (Siri & Search). Prior to iOS 11 disabling this setting for an app prevented Search from showing results from "inside" the app (e.g. Dropbox listing files). With iOS 11 this behavior has changed: now this setting must be enabled for the app itself to appear in Search results at all.

Note that while this appeared to have been "fixed" in the betas of 11.2 with a new explicit option, "Show App" to search for the app, this seems to have been released (in 11.2.1) as "Suggestions in Look Up" which doesn't achieve the same result.

  • 3
    Do I have to turn it on for every single app?
    – Manngo
    Commented Sep 24, 2017 at 6:34
  • 1
    @Manngo: It seems so. (I suspect this is a bug, especially since the unchanged description in the UI of what the setting does not match this behavior).
    – orome
    Commented Sep 24, 2017 at 18:24
  • 1
    holy cr*p! I had to disable and then enable an app for it to show up in search! this has wasted so much of my time!
    – zaf
    Commented Oct 6, 2017 at 12:25
  • @zaf Indeed. But Apple is busy evading taxes and no longer has time to worry about our time.
    – orome
    Commented Oct 6, 2017 at 12:34
  • 1
    @orome Also, this way they push their apps - especially maps.
    – zaf
    Commented Oct 6, 2017 at 12:53

Today I decided to give iOS 11.2 beta 4 a try. Though I hadn't read about this specific change, I was thrilled to see that Apple has addressed this issue! There is now a separate 'Show App' setting available on a per-app basis. It's still going to be tedious to go in to each of my 300-or-so apps to enable this, but I'm glad there's a way to again use Spotlight to launch apps.

iOS 11.2 enables new Search option

My version of this question: Fixing app search in iOS 11

  • (I didn't realize the beta ban had been lifted; though it has — a good thing!)
    – orome
    Commented Nov 23, 2017 at 20:46
  • I'm glad they fixed it!
    – orome
    Commented Nov 23, 2017 at 20:46
  • I don't see this change in any of my apps or in Siri settings. Is it not deployed yet (11.2.1)?
    – orome
    Commented Dec 21, 2017 at 13:56
  • @orome Yes the change was definitely implemented in iOS 11.2.
    – luckman212
    Commented Dec 21, 2017 at 14:13
  • Where in settings would I find it?
    – orome
    Commented Dec 21, 2017 at 14:14

Here is the solution; you need to manually turn on search results (“Search and Siri Suggestions”) for each individual app under Siri & Search settings. Once you do this it will work immediately, no need to index or plug your phone in - back to normal!

It was frustrating but when I went through the list I realized there were actually many apps that I was happy to exclude from search so that I can find the important apps even faster. Good luck!

  • That's what this answer already says. Critically, the meaning of the setting (though not its description) has changed since iOS 10.
    – orome
    Commented Sep 24, 2017 at 18:23

I don't think any of these solutions address the real problem. I'm having the same issue but I realized that you need to spell the exact name of the application you are looking for (Which is really annoying).

So in your case, you would have to search for "stack exchange". I hope Apple fixes this soon. They may have "Improved" functionality but they've broken simple app searches.

  • That addresses neither the question nor the problem.
    – orome
    Commented Sep 26, 2017 at 23:29

For iOS 11.2.1, go to Settings | Siri & Search then turn off Suggestions in Search.

Screenshot of Siri & Search

Now the top hit is an app and the first block of results is also apps:

Using iOS search to find apps that begin with the letter c

  • Almost. But this destroys the quick suggestion of recent or contextual apps when no text is entered.
    – orome
    Commented Dec 28, 2017 at 1:20
  • @orome - good point, but I have no idea how to fix that
    – Ed Norris
    Commented Jan 3, 2018 at 2:48

The indexing (and over resource dependent calculations as image scanning) is only done when connected to a power source, as far as I know. Load your phone overnight and try again tomorrow.

  • My phone was connected to a power source during the update and was still connected when I noticed that the search functionality did not find my apps.
    – marcolz
    Commented Sep 21, 2017 at 7:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .