0

I am trying to install ViTables 3 (an HDF5 file viewer) on MacOS X 10.9.5 with Python 3.6 using the following command:

pip3 install ViTables-3.0.0-py3-none-any.whl

It installs just fine but it still won't start, yielding the following error instead:

qtpy.PythonQtError: No Qt bindings could be found

I have tried the following to fix this with no luck

brew install pyqt5

brew install pyqt

Any ideas about how to fix this actually?

I have also installed Anaconda just for this and tried installing ViTables with conda (conda install -c conda-forge vitables) but it doesn't work this way too, although the error (shown when I try to run ViTables, the installation process seems to complete without errors) is different:

pkg_resources.DistributionNotFound: The 'ViTables==3.0.0' distribution was not found and is required by the application

PS: I've also tried HDFView but it says there's not enough memory to open the file I need (I am almost sure ViTables will manage - it opens the same file just fine on a much older Linux machine).

1

I don't know about the pip error and cannot check it because I've no OS X boxes available.

Regarding the conda error it is almost sure the well known conflict between pyqt5 pip package and pyqt5 conda package. A workaround is simply remove the PyQt5 dependency from the file Anaconda3\pkgs\vitables-3.0.0-0\Lib\site-packages\ViTables-3.0.0.egg-info\requires.txt (I don't know if the path is the same on Mac OS X).

You can found it explained with some more detail in the ViTables FAQ.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .