5

So I wiped my computer at work using the disk utility. I went to install the OS again and when I select the drive and hit "install" I get "The operation couldn't be completed. Permission Denied"

enter image description here

When I search for this problem it looks like most people aren't reinstalling the OS and just installing a program so their issue seems to be they are not using an Admin account or what not.

With my issue I'm not exactly logged in to any account and don't know how to give myself permission.

Does anyone have any ideas to fix this issue?

Heres a link to a reddit thread I made where some one tried to help me out so you can see what I've tried. Theres also some more screen shots in that thread.

Edit: I should add that I tried restarting and holding CommandOptionRto do an Internet recovery but when do it takes me back to macOS Utility. I assume as soon as I and it goes to that progress bar which makes me unable to hold Command to choose a boot location. I do have macOS installer on a USB drive but again, when I restart and hold Option it does the progress bar. I do have another Mac and a Thunderbolt cable but I'm not quite sure of the process to use another computer to install the OS. I'll be searching that now.

  • I restarted and held Shift, Option, Command R and it actually brought me to Internet Recovery... its doing its thing right now. – Frank Aaron Seager Sep 19 '17 at 16:43
  • No dice, I get a pop up saying "macOS could not be installed on your computer. "volume contains macOS or OSX Installation Media. Quit the installer to restart your computer and try again." – Frank Aaron Seager Sep 19 '17 at 16:59
  • 1
    You can't install onto OS X Base System, that's the Recovery volume. From Recovery, if you don't get a choice of volumes to install on, go to Disk Utility & check you have a formatted GUID/HFS+ volume you should be installing to. – Tetsujin Sep 19 '17 at 17:42
  • I only see Fusion Drive and OSX base system imgur.com/a/IvBvS . Also now all i have on the screen is a black background with White circle with a cross through it :S restarting brings me back to that circle. – Frank Aaron Seager Sep 19 '17 at 18:39
  • Ahh... you appear to have a 1TB recovery partition... not what you really want. All I could suggest would be to boot to Internet recovery & reformat the drive as a single regular partition; then install to that & it will create a new, correctly-sized recovery as it does it. – Tetsujin Sep 19 '17 at 18:44
2

This one should help it

https://discussions.apple.com/thread/7860429

Needed to erase and rename the Drive to Macintosh HD

  • 2
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – grg Dec 27 '17 at 11:28
  • Please edit your answer with the key points in the link and use the link as supporting documentation and/or for further reading. – Allan Dec 27 '17 at 15:17
  • I can't believe this worked. – Faloude Oct 10 '18 at 10:39
1

If you updated your OS to High Sierra and you want to downgrade to Sierra, make sure the partition format is Mac OS Extended not AFPS. Mine was AFPS and that's what caused the error.

1

Only do this if you have a backup and are allowed to delete everything on the internal drive

If you have access to another mac computer, you can download the app to install mojave (or whatever the right version you want is), and then use this guide to create a bootable usb drive:

Official Apple Guide

Once you have created the installation media, boot into macOS while holding Option. An icon will come up that says install macOS and then go to disk utility. Erase the disk and reformat it to APFS. If this doesn't work, go to the terminal and use diskutil list to find the right disk, and diskutil eraseDisk APFS macOS disk3. Make sure to replace the disk3 with the correct disk identifier that you got with diskutil list.

After you have prepared your internal disk, go back to install it, and it should work.

The reason this works I think is because the installation is not booting off of the internal drive, but in internet recovery it is booting off the internal drive.

-3

The operation couldn't be completed permission denied, I Am Facing the same Problem. And I Find what the issue, it's HDD Cable connector not working properly. Please replace & try again hope problem is resolved. without any Issue,

  • The asker is trying to install Sierra, not sure how your answer helps. – nohillside Nov 16 '17 at 16:23

You must log in to answer this question.

protected by bmike Oct 6 '18 at 16:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .