Almost all of my email calendar invites appear in my non-Apple email that eventually gets routed and delivered to Gmail and by me to my Google Calendar, however, for some individuals, none of their invitations come through email but instead show up in iCal as transient popup notifications, despite their inviting me with my email address.

I have a hypothesis that when they invite me using the same email address of my Apple ID and they are on some Apple device such as a laptop or iPhone, that Apple sees the email and matches it to my Apple ID and decides to short circuit the email invite (never sending it) and instead just populate directly to my iCal. I haven't tested this hypothesis because I think it would involve asking one of the few people I have this difficulty with to take the action and did not want to impose upon them if I could avoid it.

Does this hypothesis make sense, or if not, what else could be going on here and how can I stop this from happening? My end goal here is that I get an email invite in all cases and never have my iCal automatically pre-populate. My reason for this desire is that I do not use iCal but instead use Google Calendar and I end up missing these invites all together. Maybe it is as simple as just changing the email address for my Apple ID to be an address that I never get calendar invites for?

1 Answer 1


Your hypothesis is very close to reality: it seems (based on ArsTechnica article) that the default settings in Apple's iCloud calendar service automatically push calendar alerts to Apple iOS and macOS users and bypass e-mail entirely.

The same article describes how to change the settings.

Visit your iCloud account via a Web browser. Log in to iCloud and go to the Calendar Web app, click on the Settings gear icon in the bottom left corner of the Calendar view, and click Preferences. Click the "Advanced" button in the Preferences pop-up window. At the bottom of the window, change the Invitations setting for "Receive event invitations as:" from "In-app notifications" to "Email to [your iCloud account address]."

Screenshot showing the action described.

  • I have the same issue as @WilliamKF however this fix hasn't worked for me. Are there any other suggestions out there?
    – Robbie
    Commented Mar 4, 2019 at 23:45
  • It is so bizarre that this option is only available on the web. I never would have found it. Commented Jul 3, 2022 at 21:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .