19

When you first open Safari and only have one page (one tab), the tab bar is not shown. When you open your second tab (e.g. by center-clicking a link to open it in a new tab), the tab bar then appears, which makes the content of the original page jump down a bit.

I expected to find an "Always show the tab bar" checkbox in Preferences, but apparently not. (Safari 5.1)

Is there a way to force the tab bar to always appear, even if there's only one tab open?

  • Post the answer yourself now anyway, I was part way through describing it before I saw your comment. It will prevent duplicate answers etc. – stuffe Nov 1 '11 at 12:05
  • @stuffe "self-answering timeout" means he can't post an answer to his own question earlier. – Jari Keinänen Nov 1 '11 at 12:40
  • Ah, thanks for clearing that up, sorry for duff comment :) – stuffe Nov 1 '11 at 13:50
19

As it turns out, you do this through the "View" menu, rather than through "Preferences":

  1. Close all tabs but one, so you only have one tab open
  2. In the "View" menu, click "Show Tab Bar" which will make the tab bar appear
  3. This preference will stick, even if you close and reopen Safari

Simple, but not what I expected!

  • 1
    What makes this worse is the fact that the keyboard shortcut for it is CTRL-Shift-T, which in other browsers reopens the last closed tab... – user11633 Apr 11 '12 at 17:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .