1

I have my router setup with 2 frequencies:

When I'm near the router, I'm connected to the 5Ghz wifi network.

But when I go into my bedroom, I am switching to the 2.4Ghz network because the 5Ghz signal is too weak at that distance (barely getting any speed).

So I manually switch to the 2.4Ghz, but my MacBook automatically changes back to the 5Ghz network. I switch back to 2.4Ghz, it stays connected for 2-3min and then goes 5Ghz for no freaking reason.

I already placed the 2.4Ghz network at the top of the preference list in the advanced network settings, but it didn't help.

Running OS 10.11.5. Any ideas?

1
  • Most likely cause is a burst of noise or interference in the frequency range your 2.4GHz network is using (eg you are on channel 1 and a neighbor is transmitting on 1 or 3).
    – samh
    Aug 17, 2018 at 12:13

1 Answer 1

-1

Try this...

System Preferences > Network > Wi-Fi > Advanced

Drag the various wifi logins to the order you want. In your case, the 2.4GHz above the 5GHz.

wifi

3
  • thanks, but I already did that (no change) Sep 16, 2017 at 17:46
  • Maybe try removing the 5GHz login completely
    – GEdgar
    Sep 17, 2017 at 0:04
  • Do they have the same SSID? Jul 9, 2018 at 3:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .