2

I was taking taking time machine backup on a network drive in a sparsebundle image. In order to use another usb HDD (exfat) to take backup I ran the commands explained here: http://hints.macworld.com/article.php?story=20140415132734925

Now the previous backup destination is deassociated with the Time Machine and when I appended this (network) destination again using follwoing command it starts backing up from the scratch (first backup)

sudo tmutil setdestination -a  '/Volumes/MacBook-Backup/'

Can anyone tell me how do I reassociate the network sparsebundle the the my Mac as it has latest backup.

3
sudo tmutil inheritbackup "/path/to/backup.sparsebundle"

Machine directories and sparsebundles are owned by one computer at a time, and are tracked by unique identifiers rather than computer name, host name, or ethernet address. The inheritbackup verb reassigns the identity of the specified item, reconfiguring it so the current host recognizes it during backups. When inheriting a sparsebundle, the machine directory within will also be claimed.

This performs automatic inheritance of the computer and disk backups located within. This may not function correctly. If not, you may need to manually associate the disk within the backup with your current disk.

sudo tmutil associatedisk -a "/" "/Volumes/backupdisk/Backups.backupdb/computername/Latest/localdiskname"

The -a option tells associatedisk to find all snapshot volumes in the same machine directory that match the identity of MyStuff, and then perform the association on all of them.

3
  • Thanks. The 2nd command did not work with the double quotes and gave me error "/Volumes/backupdisk/Backups.backupdb/computername/Latest/localdiskname: Not a snapshot volume." But when I tried removing all the quotes it did not give any error. Backing up now. Seems it would work – user2963555 Sep 16 '17 at 22:06
  • 1
    I tried both of these commands. The first returns "Attach failed: Failed to attach disk image. (error 35)" and the second returns "Failed to gather snapshots for /Volumes/Backups..." Any ideas? The backups are definitely there on the drive. – Alan Munn Jul 24 '20 at 22:35
  • Same problem with the "Failed to gather snapshots" message as my result also. This is on Mojave. – Rocket Garden Aug 5 '20 at 7:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .