My iPhone 7 which I recently bought doesn't charge with my MacBook Pro Retina 2015. It always shows for one second that it recharges but then something like lost connection and then again. and goes on and on, both ports...

Strange thing is that my girlfriend's 6S charges in the same computer flawlessly.

  1. I have tried 5 different cables and bought 1 new one. Same result
  2. In my girlfriends Macbook air it recharges fine, also in other computers it recharges fine...
  3. The iPhone recharges okay from within the AC Charger
  4. I reseted PRAM and SMC, still the same result
  5. Other accessories work fine (Recharging camera, USB port for dock in display)

macOS Sierra, iOS 11 Golden master beta, got Xcode 9 beta installed alongside Xcode 8.

Other thing I thought about is that it could be the Xcode messing around with the USB Port. But I uninstalled it with no luck.

Q: How can I make my iPhone charge (again) using my MacBook Pro?

  • I had similar problem when I enabled wireless debugging in Xcode 9 yesterday. Restart helped in my case. Maybe reinstall Xcode and disable wireless debugging for this device? Just a guess – Mateusz Szlosek Sep 15 '17 at 11:52
  • okay, after update I uninstalled Xcode and deleted lockdown folder insides. I found out new usecase: When I am not signed in, the recharging works fine. unfortunatelly I deleted all the user Launch daemons and it still occurs... At least I know it's something user-related... – Dominik Bucher Sep 15 '17 at 17:06
  • Not a duplicate @bmike :) – Dominik Bucher Mar 7 '19 at 20:00
  • 1
    Are you able to ask on meta for some people to review this? Unless there's an edit to clarify how it's substantially different than the linked question, it won't get a review without an edit. Maybe I'm missing something, but I don't see why we keep both questions linked and what sort of additional answer might be provided here. Close just points answerers to the main thread for this. – bmike Mar 7 '19 at 21:13

Running this in terminal worked for me: (it will ask for your user's password)

sudo killall -STOP -c usbd

This pauses the troublesome process instead of killing it altogether like other answers suggest. The difference is that macOS won't try to reopen it automatically and cause the issue again.

Running sudo killall -CONT usbd will resume the process, should anything require it.

Tested on: iPhone 7 (iOS 11) + MacBook Pro Late 2013 (10.13.6)

Besides software issues, there's a good chance that the cable is at least partially damaged (or not genuine Apple) so it might work for dumb power chargers but not with a MacBook that also relies on the USB data pins.

  • 3
    Works with iOS 12 (iPhone 6S) and MacBook Pro 2015. – Dilip Raj Baral Nov 24 '18 at 9:44
  • 1
    Concerning the comment on the cable: I tried at least three almost new original Apple cables. All of them work flawlessly with my other devices (iPhone 5, iPad mini4) – n1000 Dec 21 '18 at 8:08
  • 1
    It works, but without usbd the phone will charge a lot slower and will stop charging if you let the Mac sleep. I'd try disabling it and reenabling at least once, to see if the problem goes away. Works some of the time for me. – Breno Gazzola May 7 '19 at 1:47
  • 1
    worked with macBook Mid 2015 + iPhone 8 – tronc Jun 30 '19 at 9:51
  • 2
    MacOS Catalina does not show USBD in activity monitor. But this solution still works (MBP 2015 on Catalina with iPhone 11 Pro Max on iOS 13 – channae Oct 15 '19 at 5:13

Once I force-quit the process "usbd" this problem went away.

Open Activity Monitor -> View -> All Processes -> Search for usbd -> Double click -> Quit -> Force Quit

Here are a couple of manual pages on the usbd process, for more information:

  • 5
    Please don't delete this. It's the only one that has worked for me. Deleting it would be harmful to the community. – csalvato Jun 25 '18 at 1:25
  • 3
    It worked for me too. What a hell usbd does? This a two year lasting bug... – Vinícius Ferrão Jul 27 '18 at 3:57
  • 2
    Wow! All this time I had been thinking my Mac's USB port wasn't able to supply enough power to the phone. – Dilip Raj Baral Aug 24 '18 at 14:05
  • 1
    I tried but then the phone doesn't charge anymore? – MicroMachine Dec 11 '18 at 0:27
  • 1
    THIS WORKED! I tried doing sudo killall -STOP -c usbd but it didn't do the trick. This did. Nice one! – Joshua Pinter Dec 28 '18 at 18:01

This happened to me for the longest time.

How I Fixed It:

Settings > Network For me, there was one titled 'Thunderbolt Bridge' Remove it

(Click the lock and enter your admin password, now you can hit the minus sign - for that connection.)

Then you should be all set.

On a MacBook Pro, Mid 2015 but should be a universal problem.

Maybe it has something to do with XCode like the some of the other people above were saying.


I had this issue with my MacBook Air. I contacted Apple support and they gave me a few successful options. Firstly check that your software is up to date.

If this doesn't work you'll need to Reset the System Management Console.

  1. Shut down the MacBook and plug in the charger. Ensure nothing else is connected to the device.
  2. Press Shift-Control- Alt and the power key simultaneously for 10 seconds and then release.

Youll then need to do a Reset NVRAM.

  1. Turn the MacBook on and instantly press the Command- Alt- P -R keys. (do this before the welcome screen pops up, straight after you've pressed the on key)
  2. Continue to hold the keys until the computer restarts and you hear the startup sound again.
  3. Release the keys.

This worked for me so I hope you find this helpful.

  • 2
    thanks but I posted already to question I did all the SMC and NVRAM resets... Anyways thanks for contribution:) – Dominik Bucher Jun 12 '18 at 23:52
  • 1
    If one of these 3 receipes worked, which one is it? – dan Feb 20 '19 at 7:40

The problem is caused by cache and directory issues with the startup disk. BOOTING IN SAFE MODE SOLVED IT. Boot in safe mode (hold down shift key immediately you power the macbook, keep holding it until you see the login screen). To confirm that you are in safe mode (safe mode should be written in red at the top right corner of the login screen). Login, plug in your iphone and the problem is solved. To confirm that the problem is solved, leave safe mode by just restarting the macbook normally (without holding shift). Sorry for the late response. THIS IS A 100% FIX

  • 1
    "THIS IS A 100% FIX" - nope, it's not. didn't work. – tronc Jul 1 '19 at 13:24
  • 1
    It might have been a "100% fix" for YOU, but it certainly didn't help me. – wickywills Dec 12 '19 at 9:54

Everyone is focusing on the MacBook, that isn't the issue. The USBD process is just a workaround, but the issue lies in a setting on the iPhone. If you plug your phone in before restoring your backup, the issue will not be there. The quickest way to fix this is to go to Settings>General>Reset>Reset All Settings. This isn't going to delete any of your content, it will however reset all of your settings (Screen Timeout, Notification, Wallpaper, Face/TouchID etc.), which will resolve your issue. From there, go back through and set your Settings the way you like them, and if your issue comes back, it is something you are changing in settings.


This connection problem was caused b/c the iphone was unable to connect to the itunes on my Macbook Air. I switched from generic cord to apple cord which allowed the connection to last longer before disconnecting. When asked in itunes if I wanted this computer to accept this iphone I selected yes and then I had to confirm on my iphone to trust this computer. Once this was done I had no issues and the connection was never lost again. I can even use the generic iphone cable to connect my iphone to my Macbook Air at this time. The only problem is I had to enter this information quickly before it lost connection. (Apple needs to find away to resolve this issue!) I had no problem connecting iphone to my PC Lapton and connecting to itunes and charging phone. It is only a problem with Mac. I'm using late 2016 macbook air with Macos Mojav 10.14.1. I hope that this helps!

Not the answer you're looking for? Browse other questions tagged .