0

enter image description here So I just recently noticed that my iMessages we're going in as my email instead of my number why is that? I just want somebody to help me figure out how can I get it to change into my number instead of my email I tried turning it off and doesn't work I try resetting my phone doesn't work and every time I try to click where it says my number it's all Gray with a little has a a loading icon on the left.

1

There have been some quirks with this from time to time. As you can imagine, where it says "START NEW CONVERSATIONS FROM" should have your phone number listed as an option.

Try to get it to show up by doing the following, go to "Settings -> Messages" and go to "Send as SMS" and toggle that on. This will shut off iMessages and force your phone to only send SMS messages using phone number.

Try sending a message or two before coming back, then toggle "Send as SMS" off and go back to "Settings -> Messages -> Send & Receive" and your phone number should be listed under "START NEW CONVERSATIONS FROM"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .