1

After changing region/country, News can't be opened.
App Store shows installed, with "Open" button next to the App.
Tapping on it does nothing.

Asking Siri to open it, Siri says "can't right now".
I'm using an iPhone SE and the storage is not full.
The widget shows. Tapping on articles (in widget) opens Safari.

Anyone else had this, and solved it?

  • @grgarside I'm thinking to edit it to mention that (likely) the problem began after changing country, and that the iOS change might have been around the same time by chance (see answer apple.stackexchange.com/a/299589/156518 ). The reason it might help is: people are more likely to search for News app not working after country change, now that we know iOS 11 is not the issue. – Daniel Springer Sep 24 '17 at 21:07
  • 1
    Sure, go for it! I was mainly editing the post to make the image a little smaller and also wanted to expand the title a little to make it clearer what was going on, and just went off the existing content in the question, but feel free to edit with that instead! It's an interesting question especially given how confusing I can imagine that situation being with a clear open button not working at all – grg Sep 24 '17 at 21:09
1

News App has been limited to specific countries.

You can change your country under Settings > General > Language & Region > Region to keep using News, if your country no longer has access to it otherwise.

Note: you can always use the App's widget in other countries.

More:

0

About the best troubleshooting for an installed app is:

  1. put device in Airplane mode
  2. power off device
  3. power on device
  4. try app
  5. if it fails - open up settings and be sure you have 1 GB of free space and restart again in Airplane mode
  6. if things still fail - consider enabling networking and check for updates.

Barring that - you can either delete the app and reinstall it or consider making a backup and erasing all content and settings. Then try a vanilla device with no iCloud, no personalization.

  • Damn.. Next step after those would be buying a new phone... 😂 Gonna try. Thanks! 🙏 – Daniel Springer Sep 20 '17 at 2:15
  • First thing I'm thinking is: News app obviously needs internet. – Daniel Springer Sep 20 '17 at 2:17
  • 1
    Not to open the app and tell you there’s no internet connection. I’ll buy your phone if it’s broken so that only news doesn’t work. ; - ) – bmike Sep 20 '17 at 2:17
  • 😂 ok ok I'll try it. And the other answer as well. Thanks! – Daniel Springer Sep 20 '17 at 2:18
  • Fingers crossed it’s an easy bug fix and you’re on to loving the new features, bells and whistles. – bmike Sep 20 '17 at 2:19
0

The News app cant handle a region change, which is what it uses to decide what feeds can be accessed. After changing region in settings even if you can launch the app most feeds will say “this feed is not available in your region”. The solution is to uninstall the News app and then install it again from the App Store. This process clears out its preferences and allows it to work in the new region. Works on iOS 12.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .