0

Suddenly my MacBook Pro 2017 running Sierra 10.12.6 crashed and couldn't pass the boot loop (stuck at the apple logo with the filled progress bar for hours)

Then I restarted with command+R and tried to back up my main disk to an external HDD but it fails. I got the following error:

Validating target...
Validating soruce...
Validating sizes...
Restoring    
Could not restore - Device error
Operation failed

I tried to reset NVRAM with holding down Option+Command+P+R, but did not help. When I run first aid from the Disk Utility, it says:

File system check exit code 8.
Updating boot support partitions for the volume as required.
File system verify or repair failed.
Operation failed...

I run the hardware check (command+D on restart) and it couldn't find any issues. So it is a still matter of software problem..

Then I have created a bootable USB (ownership ignored on the usb) from Sierra 10.12.6. It boots from USB well but when I try to install Sierra on my Macintosh HD got the following message:

The operation couldn't be completed. Permission denied

Do you have any suggestions on how to install Sierra again and/or backup my disk?

0

I've never had any success using the Disk Utility restore feature in data rescue scenarios. I'd install the OS on the external drive and try to pull your data from the built-in drive.

Once you're running off the external drive, more options become available.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .