2

My iPhone with iOS 10 keeps beeping every several minutes to remind me of an incoming message (and other events) until I unlock the device with passcode or fingerprint.

Is there some way to stop the repeated alerts? I want only one alert per event.

3

Settings → Notifications → Messages → Repeat Alerts and set it to Never.

For what it's worth, the default setting of repeat once means that an unread message notification will alert twice unless a subsequent message arrives or you read the message, the latter of which can be from the lock screen. This only applies to messages, not other alerts/events, and only once more than the normal notification, not continuously.

An important distinction from what you said about unlocking — you don't need to unlock, you just need to interact, so any of these will disable the second alert:

  • being the one to turn the phone on with the sleep/wake button
  • sleeping the phone after a notification with the sleep/wake button rather than letting the device time out
  • 3D Touch on a notification
  • dismiss the notification

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .