84

When I click on an external link and Google Chrome is not running yet, Chrome will launch but will not open the linked page. Instead, it starts at my last opened tab (which is the behaviour I expect), but the clicked link should also open in another tab.

When I click the link a second time, it will open correctly in a new tab.

Why is this?

EDIT:
For clarification, it's about macOS. Furthermore, I found it behaves different to how I described above. The link is opened in a new window the first time, instead of a new tab in the existing window. The problem is, that it does not come to the front, so the old window from my last session in Google Chrome is in the front. You don't notice the new window behind the old one unless you use mission control to see there is a second window.

EDIT 2:
Since this question got a lot of attention I finally accepted the top voted answer, though this wasn't my problem in the first place at all. I can see that there are two problems here:

  1. When there is a pending Chrome update, Chrome does not open the external link at all, just opens another window with the default start screen. (Bug)

  2. When Chrome is up to date, external links are opened but this time still a new window in the background and not as a new tab when restoring the last session. (bad design)

Hope this should be clear now :)

  • Chrome for macOS? You may want to expressly state if it is macOS so that moderators don't close your question as off-topic. Cheers – bjbk Sep 7 '17 at 19:51
  • @bjbk It’s fine to presume macOS and the question wouldn’t be closed for off-topic, but asking for clarification whether OP is referring to macOS or iOS is rather important for answers – grg Sep 7 '17 at 23:27
  • @grgarside I almost added iOS in the comment but for the ‘click’ reference. Great point. Thanks! – bjbk Sep 7 '17 at 23:54
  • Is this behaviour happening with all links or only a specific link? – LH16 Sep 8 '17 at 7:05
  • all links, no matter what – uloco Sep 18 '17 at 13:48
136

I had this happening all afternoon. Then I checked Chrome | About Chrome and it was waiting for me to relaunch to update. That fixed it.

  • 1
    Thanks, been having this issue for a couple days, since my last reboot... thought I was going crazy. – Tracker1 Nov 17 '17 at 1:05
  • 2
    OP, please accept this answer since it is correct. – Rafael Eyng Dec 8 '17 at 16:10
  • 1
    this worked for me too! This is happened to me in the past, I wonder it's a deliberate glitch to remind you of updating. But it's very, very annoying! – mavili Jan 4 '18 at 13:34
  • I was surprised to find this is the right answer! I think it side-effect of the big red X in Mac which doesn't close applications - ex Windows user speaking here. As apps are only hidden and Chrome is no longer showing the green "update ready" button in it's UI, we're all losing the plot. – Matt Canty Feb 15 '18 at 11:05
  • For those who are getting here and still aren't finding a solution, here's what worked for me (I don't have enough rep on this SE site to leave a real answer). In my case, it was headless Chrome processes from automated WevDriver tests that had crashed. They were capturing the link open requests. Killing them worked for me. ps aux | grep -i -- '--test-type=webdriver' | grep -v 'grep' awk '{ print $2 }' – Bo Jeanes Mar 2 '18 at 6:05
11

Try entering chrome://restart in url line and hit enter. This will fully restart Chrome and all of it's children processes including Chrome-based apps. I assume it's not the Update which helped others here, but the Chrome restart.

  • This fixed it. Previously I closed all windows of Chrome and re-opened, it didn't help. – sdkks Jan 8 '18 at 4:55
  • @sdkks when you manually close all the Chrome windows - there are still some background chrome processes left running. The command above restarts them all. – Nikita Mendelbaum Jan 15 '18 at 22:40
  • or just Cmd+Q (Kill) the app, a bit disappointed... no one knows how to prevent it? – vk.edward.li Mar 1 '18 at 9:37
9

Updating Chrome solved the issue for me.

NOTE: The problem can reproduce each time a new version of Chrome is available...

  • Updating to latest version fixed the issue for me too – Chalapathi Dec 18 '17 at 3:08
  • There's NO NEED to update Chrome to fix this. Just enter chrome://restart in URL line and hit enter to fully restart all Chrome processes. That should fix the issue. – Nikita Mendelbaum Jul 12 '18 at 7:37
4

Updating Chrome also solved this problem for me. However, I didn't know Chrome had an update waiting until I clicked on "Chrome->About Google Chrome".

1

Actually the workaround has been merged in Chromium already

https://chromium-review.googlesource.com/c/chromium/src/+/801030:

In macOS 10.13, if: - Chromium is the default browser - Chromium has updated - The user has not relaunched

and the user tries to open a link from an external program, instead of opening the link in the running instance of Chromium, LaunchServices tries to open a second instance of Chromium.

Currently, this causes the running instance to open a blank new window.

So this issue has nothing to do with the App Update, before it is released in Google Chrome we must restart the application to fix it temporary.

The actual root cause and proposed solution is here: https://bugs.chromium.org/p/chromium/issues/detail?id=777863#c56

0

I uninstalled Chrome with AppCleaner and did a fresh install. This solved the problem for me.

You must log in to answer this question.

protected by Community Dec 18 '17 at 6:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .