0

MacBook Pro 2011 OSX10.12 keeps on loading after starting to boot it. Researched the web and tried various options. Following commands were not successful:

  1. Safe Mode

I have done the following:

  1. NVRAM rebset - nothing.
  2. Recovery Mode - HD scanned and OK.
  3. Verbose Mode - it kept on looping on the airport IO80211 line.
  4. I logged into Single User Mode and disabled the WIFI. The loop disappeared, but there is a different error now, which seems to be kext file related:

    busy timeout[0], (60s), kextd wait(1): with loads of random garbage after that.
    

Note that I am no programmer!

  • Exact model and OS version? Have you tried an SMC reset? Booting from another drive? Booting from the Recovery Partition (<Cmd>+<r> or is that "Repair"? – LangLangC Sep 7 '17 at 15:11
  • If booting into Safe or Recovery mode don't help, your next best bet is to try Apple Hardware Test (AHT). Hold the D key while booting from a powered off state with the AC adapter connected. That said, I don't believe your problem is WiFi specifically. You could have a HDD problem. Be sure to post the Model of your Mac and the version of macOS you are using. – Allan Sep 7 '17 at 16:20
  • I eventually managed to boot up in recovery mode. Ran 1st aid on "Macintosh HD", and all was OK. I have a MacBook Pro 2011, OSX 10.12. The problem persists though, keeps on "loading" after login. Did try an SMC reset, bit not sure whether this was completed successfully, will try again. – Phil van der Walt Sep 7 '17 at 18:24
  • "First Aid" just verifies the file system. To properly check the disk, you need to, at minimum get the SMART status. Boot into recovery, then in Terminal issue the command diskutil info disk0 | grep -i SMART. Also, please edit your post with your MacBook model and version of macOS – Allan Sep 7 '17 at 18:57
  • Why is now SingleUser in the title? Point 4 of your description & the previous screenshot seem not a match for that. – LangLangC Sep 8 '17 at 11:24
1

Below is what I did to fix a similar problem, but I already had the root account enabled, which made it a lot easier. If root is not enabled for you, you might be able to use single user mode to accomplish a similar result (move or rename the existing home folder).

https://discussions.apple.com/thread/7502209

I had already tried resetting NVRAM and SMC. It turned out that the update to 10.11.4 didn't like my primary user account. I discovered this by successfully logging in as system administrator (root) while in Safe Boot mode. Root was already enabled using Directory Services.app (/System/Library/CoreServices/Applications/). I needed to migrate my home folder to a new account. I logged in as root, then created a new user in Users and Groups prefpane. Then I used a combination of Terminal commands and the UI to replace the new user's home folder with the one I had used for the account into which I could not log in. This explanation may risk over-simplification, but what I did was this. While logged in as root, I deleted the former user  in Users and Groups leaving the home folder unchanged, deleted the new user's home folder, used the "mv" command to change the name of the old home folder to the name of the new user's home folder, then used a command something like "chown -R new-user-name /Users/new-user-name" to give the new user permissions to the stuff in the old folder. Then I was able to log in and use my stuff. I didn't worry too much about persistent caches, so I have a bit of cleaning up to do, but the old stuff is where it should be now and everything seems to be working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .