5

I bought a new macbook pro and everything was running smoothly but some days ago I noticed that the screenshots (command+shift+3) are not saving to the Desktop (it was working before), only saving to the clipboard.

  • It is not a wrong shortcut since I can hear the screenshot sound.

  • I have already tried to Force Quit Finder or restart the Mac and none of these worked.

  • I have already tried this terminal command defaults write com.apple.screencapture location ~/Desktop/ and killall SystemUIServer but they didnt work as well.

  • I do not have DropBox Installed

I am a developer so I install new dependencies every day, it may have changed some default configurations?

2
  • What key combinations are you using to take the screenshots?
    – fsb
    Sep 7, 2017 at 13:10
  • Command + Shift + 3. (Just added this to the question to be more clear) Sep 7, 2017 at 13:14

2 Answers 2

14

I figured it out. I have the latest mac, that comes with the Touch Bar. So I noticed that when a press command+shift+4 (without the control, so it should save directly to the desktop) my Touch Bar shows this:

Touchbar Screenshot

So, as you can see, it was saving to the Clipboard, instead of the Desktop (I probably did this by touching the Touch Bar unintentionally). Then, if you did everything that I wrote at my question and nothing happened, probably this is your problem too.

How to solve this:

  • Press command+shift+4, so your Touch Bar will look like the image above.
  • So, all you got to do is change the option that is selected at the Save to: section to Desktop.

Doing this, both command+shift+3 and command+shift+4 will now save your Screen Shots to the Desktop.

2
  • this needs to be upvoted more :)
    – bsarrazin
    Oct 31, 2017 at 20:27
  • Amazing, thank you! When choosing Desktop you are still able to change the directory using the defaults write com.apple.screencapture location ~/Pictures/Screenshots/ command later.
    – dislick
    Nov 6, 2017 at 6:18
2

Instead of using this terminal command :

defaults write com.apple.screencapture location ~/Desktop/

Try a different approach using this terminal command

defaults write com.apple.screencapture location /Users/yourusername/Desktop/

Obviously replace “yourusername” with your username

2
  • i already tried this and it didn't work as well Sep 8, 2017 at 14:59
  • This worked for me just fine in Catalina. Apr 14, 2020 at 16:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .