3

OK, this is really weird. I'm on El Capitan, am developing a Java app. Yesterday I made a new release and put it in Applications on my machine, right where the previous version used to be. Went to double-click it and got told "The application "BLAHS.app" can't be opened."

I went straight to Sys Prefs, Security, and told it to open any programs at all. Still wouldn't launch. (So I set the security back up)

Right-clicking on the app and choosing Open gets the exact same message.

Then I noticed that a copy of the same release, with name "BLAHS 3.9.app" did launch. So did "BLAHS3.app" and "BLAHS .app" and even "BLAH.app". In fact it seems that any name which is not "BLAHS.app" will launch.

I've tried using chmod a+x to muck with the file permissions, even though File Matey reported that all the executable bits were already on. It made no difference.

The previous version (called "BLAHS.app") launches just fine.

The offending version also launches fine when copied to my home directory.

Has anybody met this and knows the solution? This is a codebase I've been developing for years and I've never come across it before. It's not the first time I've done a release after I ungraded to El Capitan. I don't want to have to munge the name of my program just to get the Mac to play ball! :(

  • If you rename BLAHS.app does it still fail to open? Does the md5 differ between copies? – Synesso Sep 7 '17 at 5:24
  • Yes, sorry, all of the above renaming experiments were on the offending version of the file and they all launch fine. I can't calculate md5 for the app bundles but for the two jar files (offending version and BLAHS 3.9) they are identical. – skiaddict1 Sep 7 '17 at 5:25

You must log in to answer this question.

Browse other questions tagged .