2

I have TextEdit default to plain text files. I also have "Add .txt extension to plain text files" unchecked in the "Preferences" in the "Open and Save" section.

If I perform these steps:

  1. Create new document
  2. Write some text
  3. Click on title bar to set the filename and save it
  4. Type foobar.md in the "Name" box
  5. Hit "Enter"

The result is that the file is actually named foobar.md.txt.

How can I get TextEdit to actually not add .txt to file names? And what is the point of that box in "Preferences" if it doesn't actually do anything?

6
  • What OS version are you using? Commented Sep 6, 2017 at 16:31
  • I'm on sierra 10.12.5
    – onlynone
    Commented Sep 6, 2017 at 16:47
  • I use Textedit but I don't have that problem. I just recently saved a file as .out and it worked fine. Even with txt box checked, it gave me option of using .txt or .out I'm using 10.12.6
    – Natsfan
    Commented Sep 6, 2017 at 17:49
  • @john did you click the title bar to set the name and save, or did you use File -> Save?
    – onlynone
    Commented Sep 6, 2017 at 21:31
  • I used File -> save or save as. (save as appears if you hold down the option key while clicking on file menu.)
    – Natsfan
    Commented Sep 6, 2017 at 23:26

1 Answer 1

3

Don't use the name in the title bar to change or set the file name. Use the file menu option save, or hold the option key and select save as. This lets you chose your extension name. I encountered a similar problem using title bar to name the file.

2
  • 1
    This works but negates the handy feature of duplicating a file.
    – Mr. Boy
    Commented May 8, 2018 at 12:25
  • What do you mean by "hold the option key and select save as". Where/how/when is that done? Commented May 6, 2021 at 15:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .