1

I just bought a Macbook 13 (2017) without touch bar.

I'm having this issue in which in order to make it work with my Asus PB279Q, I have to start in safe mode. Once the display is working in safe mode if I re start the macbook again to normal boot, the display will continue working just fine.

Weirdly enough, if I disconnect the display and reconnect; the screen just goes dark. I can see the screen being detected in settings, but I can't see anything on screen. In order to make it work again I need to repeat the process, 1)boot in safe mode 2) boot in normal mode again.

I'm using a Kanex usb-c to hdmi cable I bought in the Apple Store, supposedly 4k capable and compatible with mac.

Wondering if anyone has had this weird issue ?

  • 1
    Welcome to Ask Different! :) I have seen this before, but only on a Hackintosh model in which some of the contacts of the PCIe slot the GPU was plugged into were slightly damaged. Obviously not the case here! Can I ask some questions: How much 3rd party software have you already installed on the MBP? Is the Asus PB279Q also new? Also, since it's working in Safe Mode, have you tested it in Safe Mode for any length of time? Finally, after going through the boot in Safe mode and restart process, does it continue to work fine until you shutdown/restart, or will it run into problems earlier? – Monomeeth Sep 4 '17 at 4:38
  • Hey thanks! 1 - I have only installed node, chrome, and visual studio code. 2 - The PB279Q is about 4 months old, It has work NP with my windows pc, and my job issue macbook pro 15. 3 - haven't tested for a long time in safe mode. 5 - After going trough the restart it works fine until you unplug the usb-c, if you un-plug - plug it, then it wont work. Seems to me like a weird issue actually detecting the monitor, because once its working it works just fine. – Omar Gonzalez Sep 4 '17 at 5:08
1

I'm not quite sure if this qualifies as an answer because the technical issue with the Kanex cable persist. So mods feel free to delete if needed.

Yeah, the magical Apple like solution was to buy the pricey Apple proprietary usb-c Multiport Adaptor.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .