4

I apologize if this is a stupid question, but I'm not very tech-savvy. Using a iMac (21.5-inch, Mid 2010), running El Capitan version 10.11.6. Router is Amped Wireless ATHENA, High Power AC2600 Wi-Fi Router with MU-MIMO (RTA2600).

I have a Mac computer that is hardwired for Internet (I have a cable plugged into back of computer). My husband also has a computer hardwired, which is not a Mac. We also have wireless service.

Earlier we had to reboot the modem and router. Now, my husband's computer will work with Ethernet, but mine will not. I can only get connectivity with my Mac via wireless (192.168.X.XXX). I've checked network settings and it says Ethernet is connected but cannot connect to the Internet.

Why not? It is setup as DHCP. I have no clue what to do. Again, none of this happened until we rebooted/reset the router and modem.

Any help would be greatly appreciated!

I did do a "renew" as suggested and the IP address came back as 169.254.xxx.xxx. I also noticed the "router" field is blank. Subnet mask is populated.

2
  • You didn't mention which model Mac you are using nor the version of macOS - please edit your question with those details. In any event, try "renewing" your IP address (Advanced tab in Network Settings) and let us know what IP it gets. A screenshot would also be helpful.
    – Allan
    Sep 4, 2017 at 1:41
  • Allan - the IP address I shared is what showed before I did the renew. When I hit "renew" everything goes blank for a few and then populates again...with the same IP address..if that helps.
    – Kimber
    Sep 4, 2017 at 1:51

4 Answers 4

4

the IP address came back as 169.254.122.206.

The 169.254.xxx.xxx address is a "self assigned address." It gets this address because it didn't get a DHCP lease from the DHCP server. This could be due to either of the following:

  • No connection between your iMac and the router/switch
  • DHCP server is down

Check your cabling from the back of the iMac all the way to the router. Make sure everything is plugged in properly. If you look at your Network Settings, it should be "green" and say "connected".

enter image description here

If it's yellow, that means it's plugged into a switch (getting power), but not communicating with anything. Check the settings on your router to be certain that the DHCP server is up and running.

5
  • Thanks, Allan! So I checked the cable, unplugged it and plugged it back in. Watching the network settings, I saw it say "Not connected" (red) then "Connected with self-assigned IP address but no internet" (yellow). So isn't there some connectivity if I can see these changes in status? As for the it maybe being a DHCP issue, wouldn't all devices on the network have the same issue (my husband can connect just fine)? Thanks, again!
    – Kimber
    Sep 4, 2017 at 2:08
  • How do I "see" if DHCP is up and running? Where would I check that? From looking at the boxes, all lights are on/flashing green as they should. To answer your other question, the cable comes in and plugs directly into the box (so I don't think there's any other equipment).
    – Kimber
    Sep 4, 2017 at 2:20
  • To clarify - the router just has one cable going from the "modem" port (blue) connecting to the modem. The ethernet cables for both computers are plugged directly into the modem (not the wireless router). Modem brand is Arris.
    – Kimber
    Sep 4, 2017 at 3:03
  • Just restarted computer - same result. Still yellow for ethernet.
    – Kimber
    Sep 4, 2017 at 3:19
  • Try a different port and cable....switch out with hubby if necessary.
    – Allan
    Sep 4, 2017 at 3:25
2

Here are the steps I followed to solve the issue on a Mac OS Cataline:

0-Start my mac without being connected to the lan.

Note: if I connect my mac to the lan and then I start my mac I do not have to do the below steps because it works fine and my mac gets connected.

1-Connect my lan cable to my mac

2-Go to system preferences -> network

3-Select my ethernet card that is not working despite the fact that my lan cable is connected (cf. image 1 below)

enter image description here

Remove this ethernet by clicking on the minus button (cf. image 2 below)

enter image description here

Select my bluetooth card (cf. image 3 below)

enter image description here

And click on the advance settings + select « renew the dhcp » + apply + ok to exit this window

Then click on the plus button to add a new ethernet interface (cf. image 4 below)  enter image description here

Click on apply and the ethernet goes green to show that it is now connected. (cf. image 5 below)

enter image description here

The problem is not fully solved because I have to do these steps each time. It is not automatic. I need to find out how to make it automatic.

1
  • Wow this actually worked! Thanks! Jul 21, 2021 at 8:28
0

What I found is when I went into "network" in settings and where they list the Ethernet, Wi-Fi, FireWire and Bluetooth where it said I was connected I deleted the ethernet using the - sign, then added it again using the + sign and choosing ethernet in the drop down menu in interface.

0

I started with my ethernet not connecting during Catalina. Here's how I solved this problem. It was time to update, so I let my iMac Retina upgrade itself to Big Sur and the issue still remained. Having successfully tested the router gateway, I knew it had to be the iMac hardware or the OS. I did a clean install of Big Sur. I backed up my important files, used the recovery utilities to wipe my SSD, made a bootable USB drive with Big Sur onboard and did the deed. Now there are no further ethernet issues. Hope this helps you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .