Can anyone please help how I can turn off device enrollment notifications? I have purchased a MacBook Pro a year ago and after upgrading to Sierra started to receive notifications from a company that owned a laptop before. I have tried contacting Apple Service and the actual company, no luck so far. I have learned that I need to find two files:

/System/Library/LaunchAgents/com.apple.ManagedClientAgent.enrollagent.plist /System/Library/LaunchDaemons/com.apple.ManagedClient.enroll.plist

But I can't move them (and even create folders where they can be moved): /Library/LaunchAgentsDisabled and /Library/LaunchDaemonsDisabled

Please help!

  • Do you have an admin account on the machine? – Allan Sep 3 '17 at 17:53
  • I have my personal admin, but nothing associated with the device enrollment. I have tried to allow it to create an account, but couldn't - it ask for credentials and password in order to create it. – vgrinchenko Sep 3 '17 at 18:32
  • I did. It came back, unfortunately. – vgrinchenko Sep 3 '17 at 18:59
  • To clarify, you erased the drive then did a clean install? Or you just installed on top of it? – Allan Sep 3 '17 at 19:18
  • Erased and did a clean install – vgrinchenko Sep 4 '17 at 20:16

Just in case you're still confused about this issue, restart your mac in recovery mode, in terminal, type in command:

csrutil disable; reboot

This will disable system integrity protection and restart your mac.

Open your terminal again, type in command:

sudo mv /System/Library/LaunchAgents/com.apple.ManagedClientAgent.enrollagent.plist /Library/LaunchAgentsDisabled
sudo mv /System/Library/LaunchDaemons/com.apple.ManagedClient.enroll.plist /Library/LaunchDaemonsDisabled

This should do the trick.

However, don't for get to re-enable your system integrity protection by restarting your mac in recovery mode, typing in command:

csrutil enable

You can check your SIP status with command:

csrutil status

Good luck!

| improve this answer | |
  • This will not work because Catalina wont allow you to change the folder. It is a read only file system. – derek May 16 at 20:00

From your admin account, open System Preferences and click on the profiles icon. This should show you the profiles and pending profiles that you may have installed. If you can, remove any existing profiles.

If that does not resolve the problem, search the disk for any .mobileconfig files and either remove or rename their extensions. Profiles that have not yet been installed live in .mobileconfig files (often found in downloads folders).

| improve this answer | |
  • There are no other profiles installed, but mine. Device Enrollment wants to install the profile, but no success so far. After doing the search, I wasn't able to find any files with the extension ".mobileconfig" – vgrinchenko Sep 4 '17 at 20:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .