2

How do I mount an encrypted disk in single-user mode? I tried using one of the answers to “How can I mount an encrypted disk from the command line?”; but when I tried using “diskutil” as suggested, I got an error saying it’s unable to run.

I booted into single-user mode, ran the two commands that are then listed after “To mount the root device as read-write”, and then got this message when trying to use “diskutil”:

localhost:/ root# diskutil list
Unable to run because unable to use the DiskManagement framework.
Common reasons include, but are not limited to, the DiskArbitration
framework being unavailable due to being booted in single-user mode.

There's a question on “How do I load the DiskManagement framework in single user mode?”, but none of the answers seem to provide a way to run “diskutil”.

The disk, a microSD card encased in a Nifty Minidrive, was set up as encrypted using Disk Utility. How do I mount it in single-user mode?

  • Single user mode prevents many utilities, like diskutil from running. This very handy page at Westwind may contain information on how you can load the frameworks diskutil needs to run. The Starting system daemons and components section is of particular interest in this regard. – IconDaemon Sep 2 '17 at 12:17
  • I found a few pages on getting diskutil to run in single-user mode on earlier versions of macOS (like sabiancrash.blogspot.be/2011/06/…), but nothing that I could get to work on macOS Sierra. An alternative is to use Recovery Mode which allows using Disk Utility to mount the disk and Terminal to run any shell commands. – Rinzwind Sep 3 '17 at 12:13

You must log in to answer this question.

Browse other questions tagged .